summaryrefslogtreecommitdiff
path: root/guix/build/pyproject-build-system.scm
diff options
context:
space:
mode:
Diffstat (limited to 'guix/build/pyproject-build-system.scm')
-rw-r--r--guix/build/pyproject-build-system.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/guix/build/pyproject-build-system.scm b/guix/build/pyproject-build-system.scm
index c69ccc9d64..295542f317 100644
--- a/guix/build/pyproject-build-system.scm
+++ b/guix/build/pyproject-build-system.scm
@@ -168,6 +168,8 @@ builder.build_wheel(sys.argv[2], config_settings=config_settings)"
(if (null? test-flags)
'("test" "-v")
test-flags)))
+ ('python
+ (apply invoke "python" test-flags))
;; The developer should explicitly disable tests in this case.
(else (raise (condition (&test-system-not-found))))))
(format #t "test suite not run~%")))