summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f37ca731d5..0e82c3b674 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10322,6 +10322,29 @@ These should be used in preference to using a backslash for line continuation.
@end quotation")
(license license:asl2.0)))
+(define-public python-flake8-debugger
+ (package
+ (name "python-flake8-debugger")
+ (version "4.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8-debugger" version))
+ (sha256
+ (base32 "0h1qlzbxxhjsw6kg3mcml9h8byy77m9a5z06z2dnvqs115b05c2j"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests in PyPI and no setup.py in GitHub
+ (propagated-inputs
+ (list python-flake8 python-pycodestyle))
+ (home-page "https://github.com/jbkahn/flake8-debugger")
+ (synopsis "@code{ipdb} and @code{pdb} statement checker plugin for flake8")
+ (description "This package provides a Flake8 plugin that checks for
+@code{ipdb} and @code{pdb} imports and set traces, as well as
+@code{from IPython.terminal.embed}, @code{import InteractiveShellEmbed}
+and @code{InteractiveShellEmbed()()}.")
+ (license license:expat)))
+
(define-public python-flake8-implicit-str-concat
(package
(name "python-flake8-implicit-str-concat")