summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ee402bad4d..9eea11f4cf 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5380,3 +5380,35 @@ filtered, pitch shifted and ultimately disintegrated. This is an unofficial
port of the Regrader plugin created by Igorski. It is available as an LV2
plugin and a standalone JACK application.")
(license license:expat)))
+
+(define-public shiru-lv2
+ (let ((commit "08853f99140012234649e67e5647906fda74f6cc")
+ (revision "1"))
+ (package/inherit dragonfly-reverb
+ (name "shiru-lv2")
+ (version (git-version "0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/linuxmao-org/shiru-plugins.git")
+ (commit commit)
+ ;; Bundles a specific commit of the DISTRHO plugin framework.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00rf6im3rhg98h60sgl1r2s37za5vr5h14pybwi07h8zbc8mi6fm"))))
+ (inputs
+ `(("cairo", cairo)
+ ("glu", glu)
+ ("jack", jack-1)
+ ("lv2", lv2)
+ ("mesa", mesa)
+ ("pango", pango)))
+ (synopsis "Audio plugin collection")
+ (description "Shiru plugins is a collection of audio plugins created
+ by Shiru, ported to LV2 by the Linux MAO project using the DISTRHO plugin
+ framework.")
+ (home-page "http://shiru.untergrund.net/software.shtml")
+ (license license:wtfpl2))))