summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6aa35710e5..99db702dbf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9468,6 +9468,11 @@ to the user's query of interest.")
(build-system gnu-build-system)
(arguments
`(#:configure-flags (list "--with-ncurses")
+ ;; The samtools test suite (and software) expects SSE-based math, even on
+ ;; i686-linux, and not 387-based math. Adjust the CPPFLAGS accordingly.
+ ,@(if (target-x86-32?)
+ `(#:make-flags (list "CPPFLAGS = -msse -mfpmath=sse"))
+ '())
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-tests