summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index cf9116214c..52710b4687 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -48,6 +48,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module ((guix build utils) #:select (alist-replace))
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
@@ -1829,6 +1830,17 @@ typically used to document the public API of GTK+ and GNOME libraries, but it
can also be used to document application code.")
(license license:gpl2+)))
+;; This is a variant of the 'gtk-doc' package that is not updated often. It
+;; is intended to be used as a native-input at build-time only. This allows
+;; the main 'gtk-doc', 'dblatex' and 'imagemagick' packages to be freely
+;; updated on the 'master' branch without triggering an excessive number of
+;; rebuilds.
+(define-public gtk-doc/stable
+ (hidden-package
+ (package/inherit gtk-doc
+ (inputs (alist-replace "dblatex" `(,dblatex/stable)
+ (package-inputs gtk-doc))))))
+
(define-public gtk-engines
(package
(name "gtk-engines")