summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/apl.scm50
-rw-r--r--gnu/packages/autogen.scm4
-rw-r--r--gnu/packages/base.scm9
-rw-r--r--gnu/packages/bison.scm4
-rw-r--r--gnu/packages/cflow.scm4
-rw-r--r--gnu/packages/complexity.scm49
-rw-r--r--gnu/packages/freeipmi.scm4
-rw-r--r--gnu/packages/gnunet.scm4
-rw-r--r--gnu/packages/gnuzilla.scm97
-rw-r--r--gnu/packages/gvpe.scm48
-rw-r--r--gnu/packages/kde.scm37
-rw-r--r--gnu/packages/lightning.scm4
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/packages/parallel.scm47
-rw-r--r--gnu/packages/qt.scm72
-rw-r--r--gnu/packages/sdl.scm47
-rw-r--r--gnu/packages/version-control.scm6
17 files changed, 436 insertions, 54 deletions
diff --git a/gnu/packages/apl.scm b/gnu/packages/apl.scm
new file mode 100644
index 0000000000..5750abbddf
--- /dev/null
+++ b/gnu/packages/apl.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages apl)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((gnu packages gettext)
+ #:renamer (symbol-prefix-proc 'guix:))
+ #:use-module (gnu packages maths)
+ #:use-module (gnu packages readline))
+
+(define-public apl
+ (package
+ (name "apl")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1myinxa0m3y4fanpxflfakfk3m1s8641wdlbwbs0vg5yp10xm0m3"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/apl/")
+ (inputs
+ `(("gettext" ,guix:gettext)
+ ("lapack" ,lapack)
+ ("readline" ,readline)))
+ (synopsis "APL interpreter")
+ (description
+ "GNU APL is a free interpreter for the programming language APL. It is
+an implementation of the ISO standard 13751.")
+ (license gpl3+)))
diff --git a/gnu/packages/autogen.scm b/gnu/packages/autogen.scm
index 3109c2bf0b..9615c1e065 100644
--- a/gnu/packages/autogen.scm
+++ b/gnu/packages/autogen.scm
@@ -28,7 +28,7 @@
(define-public autogen
(package
(name "autogen")
- (version "5.18.1")
+ (version "5.18.2")
(source
(origin
(method url-fetch)
@@ -37,7 +37,7 @@
version ".tar.gz"))
(sha256
(base32
- "0k0gkr5inr9wb3ws30q6bbiqg3qm3ryvl9cznym2xis4lm216d53"))))
+ "0s2021bwpq6h199cbbranz96hhm5s7v66lc68h8v198vqbg049yc"))))
(build-system gnu-build-system)
(inputs `(("which" ,which)
("guile" ,guile-2.0)))
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 7de7689b24..e835b418b2 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -49,19 +49,14 @@
(define-public hello
(package
(name "hello")
- (version "2.8")
+ (version "2.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/hello/hello-" version
".tar.gz"))
(sha256
- (base32 "0wqd8sjmxfskrflaxywc7gqw7sfawrfvdxd9skxawzfgyy0pzdz6"))))
+ (base32 "19qy37gkasc4csb1d3bdiz9snn8mir2p3aj0jgzmfv0r2hi7mfzc"))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags
- `("--disable-dependency-tracking"
- ,(string-append "--with-gawk=" ; for illustration purposes
- (assoc-ref %build-inputs "gawk")))))
- (inputs `(("gawk" ,gawk)))
(synopsis "Hello, GNU world: An example GNU package")
(description
"GNU Hello prints the message \"Hello, world!\" and then exits. It
diff --git a/gnu/packages/bison.scm b/gnu/packages/bison.scm
index 8782096cf0..b0eab278e3 100644
--- a/gnu/packages/bison.scm
+++ b/gnu/packages/bison.scm
@@ -30,7 +30,7 @@
(define bison
(package
(name "bison")
- (version "3.0")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
@@ -38,7 +38,7 @@
version ".tar.xz"))
(sha256
(base32
- "1j14fqgi9wzqgsy4fhkcdrv4hv6rrvhvn84axs520w9b022mbb79"))))
+ "1jx2ymvhl6h2jq6sf0lrk7ggfc2v1ri49yib8ppir0vdnh1znkll"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)))
(inputs `(("flex" ,flex)))
diff --git a/gnu/packages/cflow.scm b/gnu/packages/cflow.scm
index 52552e3fe1..76ab5506d6 100644
--- a/gnu/packages/cflow.scm
+++ b/gnu/packages/cflow.scm
@@ -35,6 +35,10 @@
(base32
"1jkbq97ajcf834z68hbn3xfhiz921zhn39gklml1racf0kb3jzh3"))))
(build-system gnu-build-system)
+
+ ;; Needed to have cflow-mode.el installed.
+ (native-inputs `(("emacs" ,emacs)))
+
(home-page "http://www.gnu.org/software/cflow/")
(synopsis "Create a graph of control flow within a program")
(description
diff --git a/gnu/packages/complexity.scm b/gnu/packages/complexity.scm
new file mode 100644
index 0000000000..5216b7e39c
--- /dev/null
+++ b/gnu/packages/complexity.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages complexity)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix licenses)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages texinfo)
+ #:use-module (gnu packages autogen))
+
+(define-public complexity
+ (package
+ (name "complexity")
+ (version "1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/complexity/complexity-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1aad7n35ymxbj5dlpvm64dcd71b6i7hbmps0g7nkf47vj53l6y2j"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("texinfo" ,texinfo)
+ ("autogen" ,autogen)))
+ (home-page "http://www.gnu.org/software/complexity/")
+ (synopsis "Analyze complexity of C functions")
+ (description
+ "GNU complexity provides tools for finding procedures that are
+convoluted, overly long or otherwise difficult to understand. This
+may help in learning or reviewing unfamiliar code or perhaps
+highlighting your own code that seemed comprehensible when you wrote it.")
+ (license gpl3+)))
diff --git a/gnu/packages/freeipmi.scm b/gnu/packages/freeipmi.scm
index 06917e1949..34b577b6f8 100644
--- a/gnu/packages/freeipmi.scm
+++ b/gnu/packages/freeipmi.scm
@@ -27,14 +27,14 @@
(define-public freeipmi
(package
(name "freeipmi")
- (version "1.3.2")
+ (version "1.3.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/freeipmi/freeipmi-"
version ".tar.gz"))
(sha256
(base32
- "1gz2r3zp8ag4cd5cflh4fy8mpvwcx1wdr37mkqkph3m5lx2w48qb"))))
+ "0pmgr66k4cx0gdwzfby6643m15bb4q2yx2g5r2jr3qidrfyxhi3j"))))
(build-system gnu-build-system)
(inputs
`(("readline" ,readline) ("libgcrypt" ,libgcrypt)))
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 35be20a3af..0f5f32b9b4 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -38,14 +38,14 @@
(define-public libextractor
(package
(name "libextractor")
- (version "1.1")
+ (version "1.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libextractor/libextractor-"
version ".tar.gz"))
(sha256
(base32
- "1zvj64ig456c9ya3r8ib48ms42cnli9y7ig5p04xqm16z7vw5dyb"))))
+ "1n7z6s5ils6xmf6b0z1xda41maxj94c1n6wlyyxmacs5lrkh2a96"))))
(build-system gnu-build-system)
;; WARNING: Checks require /dev/shm to be in the build chroot, especially
;; not to be a symbolic link to /run/shm.
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
new file mode 100644
index 0000000000..ff7de4fe96
--- /dev/null
+++ b/gnu/packages/gnuzilla.scm
@@ -0,0 +1,97 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gnuzilla)
+ #:use-module (gnu packages)
+ #:use-module ((guix licenses)
+ #:renamer (symbol-prefix-proc 'license:))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gstreamer)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages yasm)
+ #:use-module (gnu packages zip))
+
+(define-public icecat
+ (package
+ (name "icecat")
+ (version "24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gnuzilla/"
+ (substring version 0 (string-index version #\.))
+ "/icecat-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vxzjwmhad6yxx4sk9zvapjgv5salcv10id061q0991ii3dycy9a"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("dbus" ,dbus)
+ ("dbus-glib" ,dbus-glib)
+ ("glib" ,glib)
+ ("gstreamer" ,gstreamer-0.10)
+ ("gst-plugins-base" ,gst-plugins-base-0.10)
+ ("gtk+" ,gtk+-2)
+ ("libxt" ,libxt)
+ ("mesa" ,mesa)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2) ; Python 3 not supported
+ ("python2-pysqlite" ,python2-pysqlite)
+ ("unzip" ,unzip)
+ ("yasm" ,yasm)
+ ("zip" ,zip)))
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (alist-cons-before
+ 'patch-source-shebangs 'sanitise
+ (lambda _
+ ;; delete dangling symlinks
+ (delete-file "browser/base/content/.#aboutDialog.xul")
+ (delete-file "browser/base/content/abouthome/.#aboutHome.xhtml")
+ (delete-file "browser/branding/unofficial/content/.#aboutHome.xhtml")
+ (delete-file "toolkit/crashreporter/google-breakpad/autotools/compile"))
+ (alist-replace
+ 'configure
+ ;; configure does not work followed by both "SHELL=..." and
+ ;; "CONFIG_SHELL=..."; set environment variables instead
+ (lambda* (#:key outputs configure-flags #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "SHELL" (which "bash"))
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero? (system* "./configure"
+ (string-append "--prefix=" out)
+ "--disable-webrtc")))) ; webrtc creates an error
+ %standard-phases))))
+ (home-page "http://www.gnu.org/software/gnuzilla/")
+ (synopsis "Entirely free browser derived from Mozilla Firefox")
+ (description
+ "IceCat is the GNU version of the Firefox browser. It is entirely free
+software, which does not recommend non-free plugins and addons. It also
+features extra privacy-protecting features built in.")
+ (license license:mpl2.0))) ; and others, see toolkit/content/license.html
diff --git a/gnu/packages/gvpe.scm b/gnu/packages/gvpe.scm
new file mode 100644
index 0000000000..1018428306
--- /dev/null
+++ b/gnu/packages/gvpe.scm
@@ -0,0 +1,48 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gvpe)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:select (gpl3+))
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages openssl)
+ #:use-module ((gnu packages compression) #:select (zlib)))
+
+(define-public gvpe
+ (package
+ (name "gvpe")
+ (version "2.25")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gvpe/gvpe-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1gsipcysvsk80gvyn9jnk9g0xg4ng9yd5zp066jnmpgs52d2vhvk"))))
+ (build-system gnu-build-system)
+ (home-page "http://software.schmorp.de/pkg/gvpe.html")
+ (inputs `(("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (synopsis "Secure VPN among multiple nodes over an untrusted network")
+ (description
+ "The GNU Virtual Private Ethernet creates a virtual network
+with multiple nodes using a variety of transport protocols. It works
+by creating encrypted host-to-host tunnels between multiple
+endpoints.")
+ (license gpl3+)))
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 3da261ccd1..aaf425db63 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -17,11 +17,15 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages kde)
- #:use-module ((guix licenses) #:select (bsd-2))
+ #:use-module ((guix licenses) #:select (bsd-2 lgpl2.1+))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system cmake)
- #:use-module (gnu packages qt))
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages xorg))
(define-public automoc4
(package
@@ -44,3 +48,32 @@
(synopsis "build tool for KDE")
(description "KDE desktop environment")
(license bsd-2)))
+
+(define-public phonon
+ (package
+ (name "phonon")
+ (version "4.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.kde.org/stable/" name
+ "/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1sxrnwm16dxy32xmrqf26762wmbqing1zx8i4vlvzgzvd9xy39ac"))))
+ (build-system cmake-build-system)
+ ;; FIXME: Add interpreter ruby once available.
+ ;; Add optional input libqtzeitgeist.
+ (inputs
+ `(("automoc4" ,automoc4)
+ ("glib" ,glib)
+ ("libx11" ,libx11)
+ ("pkg-config" ,pkg-config)
+ ("pulseaudio" ,pulseaudio)
+ ("qt" ,qt-4)))
+ (arguments
+ `(#:tests? #f)) ; no test target
+ (home-page "http://phonon.kde.org/")
+ (synopsis "Qt 4 multimedia API")
+ (description "KDE desktop environment")
+ (license lgpl2.1+)))
diff --git a/gnu/packages/lightning.scm b/gnu/packages/lightning.scm
index 03255e0617..8ec433e0b8 100644
--- a/gnu/packages/lightning.scm
+++ b/gnu/packages/lightning.scm
@@ -25,14 +25,14 @@
(define-public lightning
(package
(name "lightning")
- (version "2.0.1")
+ (version "2.0.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/lightning/lightning-"
version ".tar.gz"))
(sha256
(base32
- "1cc19rpgrqvpkzb19ffsxw3k254m46npbkx8cbgv3dbxjf9sf4v5"))))
+ "100ya7dx12403gimif7p2q7ahd8vxqrxpxqzqr1zqci825nb0b43"))))
(build-system gnu-build-system)
(synopsis "Library for generating assembly code at runtime")
(description
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7176c37a87..e1f8b4f46d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -145,7 +145,7 @@
(license gpl2+)))
(define-public linux-libre
- (let* ((version "3.11")
+ (let* ((version "3.12")
(build-phase
'(lambda* (#:key system #:allow-other-keys #:rest args)
(let ((arch (car (string-split system #\-))))
@@ -191,7 +191,7 @@
(uri (linux-libre-urls version))
(sha256
(base32
- "1vlk04xkvyy1kc9zz556md173rn1qzlnvhz7c9sljv4bpk3mdspl"))))
+ "0drjxm9h2k9bik2mhrqqqi6cm5rn2db647wf0zvb58xldj0zmhb6"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)
("bc" ,bc)
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
new file mode 100644
index 0000000000..946e1acb6d
--- /dev/null
+++ b/gnu/packages/parallel.scm
@@ -0,0 +1,47 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages parallel)
+ #:use-module (guix packages)
+ #:use-module (guix licenses)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages perl))
+
+(define-public parallel
+ (package
+ (name "parallel")
+ (version "20131022")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/parallel/parallel-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1ydn8aj72wfjdvldzjwah9cvqay8vzr3dbspa5l0g2y10dx0qa4k"))))
+ (build-system gnu-build-system)
+ (inputs `(("perl" ,perl)))
+ (home-page "http://www.gnu.org/software/parallel/")
+ (synopsis "Build and execute command lines in parallel")
+ (description
+ "GNU Parallel is a tool for executing shell jobs in parallel using one
+or more computers. Jobs can consist of single commands or of scripts
+and they are executed on lists of files, hosts, users or other items.")
+ (license gpl3+)))
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2a0872bcdc..6aa467acef 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -118,22 +118,28 @@ X11 (yet).")
(("/bin/pwd") (which "pwd")))
;; do not pass "--enable-fast-install", which makes the
;; configure process fail
- (zero? (system* "./configure"
- "-verbose"
- "-prefix" out
- "-opensource"
- "-confirm-license"
- ;; drop all special machine instructions
- "-no-sse2"
- "-no-sse3"
- "-no-ssse3"
- "-no-sse4.1"
- "-no-sse4.2"
- "-no-avx"
- "-no-avx2"
- "-no-neon"
- "-no-mips_dsp"
- "-no-mips_dspr2"))))
+ (zero? (system*
+ "./configure"
+ "-verbose"
+ "-prefix" out
+ "-opensource"
+ "-confirm-license"
+ ;; drop special machine instructions not supported
+ ;; on all instances of the target
+ ,@(if (string-prefix? "x86_64"
+ (or (%current-target-system)
+ (%current-system)))
+ '()
+ '("-no-sse2"))
+ "-no-sse3"
+ "-no-ssse3"
+ "-no-sse4.1"
+ "-no-sse4.2"
+ "-no-avx"
+ "-no-avx2"
+ "-no-neon"
+ "-no-mips_dsp"
+ "-no-mips_dspr2"))))
%standard-phases)))
(home-page "http://qt-project.org/")
(synopsis "Cross-platform GUI library")
@@ -165,20 +171,26 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(("/bin/pwd") (which "pwd")))
;; do not pass "--enable-fast-install", which makes the
;; configure process fail
- (zero? (system* "./configure"
- "-verbose"
- "-prefix" out
- "-opensource"
- "-confirm-license"
- ;; drop all special machine instructions
- "-no-mmx"
+ (zero? (system*
+ "./configure"
+ "-verbose"
+ "-prefix" out
+ "-opensource"
+ "-confirm-license"
+ ;; drop special machine instructions not supported
+ ;; on all instances of the target
+ ,@(if (string-prefix? "x86_64"
+ (or (%current-target-system)
+ (%current-system)))
+ '()
+ '("-no-mmx"
"-no-3dnow"
"-no-sse"
- "-no-sse2"
- "-no-sse3"
- "-no-ssse3"
- "-no-sse4.1"
- "-no-sse4.2"
- "-no-avx"
- "-no-neon"))))
+ "-no-sse2"))
+ "-no-sse3"
+ "-no-ssse3"
+ "-no-sse4.1"
+ "-no-sse4.2"
+ "-no-avx"
+ "-no-neon"))))
%standard-phases)))))
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index ceb21735bc..e8fd65cf5c 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -23,8 +23,53 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages xorg)
- #:export (libmikmod))
+ #:export (sdl
+ sdl2
+ libmikmod))
+
+(define sdl
+ (package
+ (name "sdl")
+ (version "1.2.15")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://libsdl.org/release/SDL-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "005d993xcac8236fpvd1iawkz4wqjybkpn8dbwaliqz5jfkidlyn"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f)) ; no check target
+ (inputs `(("libx11" ,libx11)
+ ("libxrandr" ,libxrandr)
+ ("mesa" ,mesa)
+ ("alsa-lib" ,alsa-lib)
+ ("pkg-config" ,pkg-config)
+ ("pulseaudio" ,pulseaudio)))
+ (synopsis "Cross platform game development library")
+ (description "Simple DirectMedia Layer is a cross-platform development
+library designed to provide low level access to audio, keyboard, mouse,
+joystick, and graphics hardware.")
+ (home-page "http://libsdl.org/")
+ (license lgpl2.1)))
+
+(define sdl2
+ (package (inherit sdl)
+ (name "sdl2")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://libsdl.org/release/SDL2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0y3in99brki7vc2mb4c0w39v70mf4h341mblhh8nmq4h7lawhskg"))))
+ (license bsd-3)))
(define libmikmod
(package
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6c0328556e..3d88ff8a4a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages apr)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages ed)
#:use-module (gnu packages nano)
#:use-module (gnu packages openssl)
#:use-module (gnu packages perl)
@@ -262,15 +263,16 @@ projects, from individuals to large-scale enterprise operations.")
(define-public rcs
(package
(name "rcs")
- (version "5.9.0")
+ (version "5.9.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/rcs/rcs-"
version ".tar.xz"))
(sha256
(base32
- "0w26vsx732dcmb5qfhlkkzvrk1sx6d74qibrn914n14j0ci90jcq"))))
+ "1376amzaj7x6ar3xi1dldc0hgfa3n7412c46wqk2h2f2lf67jsk0"))))
(build-system gnu-build-system)
+ (native-inputs `(("ed" ,ed)))
(home-page "http://www.gnu.org/software/rcs/")
(synopsis "Per-file local revision control system")
(description