summaryrefslogtreecommitdiff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 02561c5442..6d2d9ea09b 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -368,6 +368,7 @@ integrate Windows applications into your desktop.")
(base32
"1d0gbwc8ll4mfxilw9j4vdzqlnracr6y8iss27nfg1qh0q7vbf9x"))))
(inputs `(("autoconf" ,autoconf) ; for autoreconf
+ ("faudio" ,faudio)
("ffmpeg" ,ffmpeg)
("gtk+" ,gtk+)
("libva" ,libva)
@@ -406,7 +407,10 @@ integrate Windows applications into your desktop.")
(script (string-append (assoc-ref %build-inputs
"wine-staging-patchset-data")
"/share/wine-staging/patches/patchinstall.sh")))
- (invoke script (string-append "DESTDIR=" ".") "--all")
+ ;; Exclude specific patches that conflict with FAudio.
+ (invoke script (string-append "DESTDIR=" ".") "--all" "-W"
+ "xaudio2-revert" "-W" "xaudio2_CommitChanges" "-W"
+ "xaudio2_7-WMA_support" "-W" "xaudio2_7-CreateFX-FXEcho")
#t)))
(add-after 'configure 'patch-dlopen-paths
;; Hardcode dlopened sonames to absolute paths.
@@ -482,7 +486,10 @@ integrated into the main branch.")
(script (string-append (assoc-ref %build-inputs
"wine-staging-patchset-data")
"/share/wine-staging/patches/patchinstall.sh")))
- (invoke script (string-append "DESTDIR=" ".") "--all")
+ ;; Exclude specific patches that conflict with FAudio.
+ (invoke script (string-append "DESTDIR=" ".") "--all" "-W"
+ "xaudio2-revert" "-W" "xaudio2_CommitChanges" "-W"
+ "xaudio2_7-WMA_support" "-W" "xaudio2_7-CreateFX-FXEcho")
#t)))
(add-after 'install 'copy-wine32-binaries
(lambda* (#:key outputs #:allow-other-keys)