summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm37
1 files changed, 35 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 923b39ee8f..4901f116e3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -65,6 +65,7 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages base)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
@@ -254,7 +255,7 @@ data.")
(define-public json-c
(package
(name "json-c")
- (version "0.12")
+ (version "0.12.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -262,7 +263,7 @@ data.")
version ".tar.gz"))
(sha256
(base32
- "0gwzic3ifg2d0w32ya3agpxh8i083cgvf7kmc51cnbgqnfr02300"))
+ "08qibrq29a5v7g23wi5icy6l4fbfw90h9ccps6vq0bcklx8n84ra"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -3737,3 +3738,35 @@ standalone and does not need inetd or ucspi-tcp. It does not need any
config files---you only have to specify the www root.")
(home-page "https://unix4lyfe.org/darkhttpd/")
(license l:isc)))
+
+(define-public goaccess
+ (package
+ (name "goaccess")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://tar.goaccess.io/goaccess-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1w84y61f3ldg2f28q6qlyr1scn3mcx0bsbq3i5xi5w193wh3xa2q"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "src/error.h"
+ (("__DATE__") "\"1970-01-01\"")
+ (("__TIME__") "\"00:00:00\"")))))
+ (build-system gnu-build-system)
+ (inputs
+ ;; TODO: Add dependency on geoip-tools.
+ `(("glib" ,glib)
+ ("ncurses" ,ncurses)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://goaccess.io")
+ (synopsis "Analyze Web server logs in real time")
+ (description
+ "GoAccess is a real-time web log analyzer and interactive viewer that
+runs in a terminal or through your browser. It provides fast and valuable
+HTTP statistics for system administrators that require a visual server report
+on the fly.")
+ (license l:x11)))