summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a71a0e07a3..d4149b571f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -96,6 +96,7 @@
#:use-module (guix build-system cargo)
#:use-module (guix build-system cmake)
#:use-module (guix build-system copy)
+ #:use-module (guix build-system dune)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
@@ -178,6 +179,7 @@
#:use-module (gnu packages networking)
#:use-module (gnu packages node)
#:use-module (gnu packages nss)
+ #:use-module (gnu packages ocaml)
#:use-module (gnu packages openldap)
#:use-module (gnu packages openstack)
#:use-module (gnu packages package-management)
@@ -8833,6 +8835,48 @@ Instead of packing all functionality into kiln itself, the core is lightweight
and can be extended with the use of external commands.")
(license license:expat)))
+(define-public soupault
+ (package
+ (name "soupault")
+ (version "4.10.0")
+ (home-page "https://soupault.app/")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PataphysicalSociety/soupault")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17jxxlrxpwsmhn9g7zf36pq842vh7l8122f4v1jbm3qh1rdx2ils"))))
+ (build-system dune-build-system)
+ (inputs (list ocaml-base64
+ ocaml-camomile
+ ocaml-containers
+ ocaml-csv
+ ocaml-digestif
+ ocaml-ezjsonm
+ ocaml-fileutils
+ ocaml-fmt
+ ocaml-jingoo
+ ocaml-lambdasoup
+ ocaml-lua-ml
+ ocaml-logs
+ ocaml-markup
+ ocaml-odate
+ ocaml-otoml
+ ocaml-re
+ ocaml-spelll
+ ocaml-tsort
+ ocaml-yaml))
+ (synopsis "Static website management tool")
+ (description
+ "A static website generator/framework that works with HTML
+element trees and can automatically manipulate them. It can be described as a
+robotic webmaster that can edit HTML pages according to your rules, but
+doesn’t get tired of editing them.")
+ (license license:expat)))
+
(define-public siege
(package
(name "siege")