summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm66
1 files changed, 47 insertions, 19 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0c7c496c82..d985c531d0 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2017, 2020 EuAndreh <eu@euandre.org>
;;; Copyright © 2017, 2018, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
-;;; Copyright © 2017, 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2017, 2020, 2024 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
@@ -1131,8 +1131,8 @@ collaboration using typical untrusted file hosts or services.")
(license license:gpl3+)))
(define-public cgit
- (let ((commit "8905003cba637e5b18069e625cd4f4c05ac30251")
- (rev "2"))
+ (let ((commit "dbadd856ba0537110338cfe58256b152d01388c0")
+ (rev "3"))
(package
(name "cgit")
;; Update the ‘git-source’ input as well.
@@ -1144,7 +1144,7 @@ collaboration using typical untrusted file hosts or services.")
(commit commit)))
(sha256
(base32
- "1ha8d2n59mv89vv4bqgg3dk82n1rqh8kd8y654vqx7v1v7m645qz"))
+ "1r9mafmjgi3hknv88a1ypym6qvy2qzs1i3n6z22ddg8q4sb1wjvk"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -1220,9 +1220,9 @@ collaboration using typical untrusted file hosts or services.")
(method url-fetch)
;; cgit is tightly bound to git. Use GIT_VER from the Makefile,
;; which may not match the current (package-version git).
- (uri "mirror://kernel.org/software/scm/git/git-2.44.0.tar.xz")
+ (uri "mirror://kernel.org/software/scm/git/git-2.45.0.tar.xz")
(sha256
- (base32 "1qqxd3pdsca6m93lxxkz9s06xs1sq0ah02lhrr0a6pjvrf6p6n73"))))
+ (base32 "0a9ljpjypszj9cxq5lk9zq8bq9v87h9fn9ph3zgyfxk4s05j1b0a"))))
("bash-minimal" ,bash-minimal)
("openssl" ,openssl)
("python" ,python)
@@ -3068,19 +3068,35 @@ by rclone usable with git-annex.")
(license license:gpl3+)))
(define-public fossil
+ (define (fossil-patch name from to hash)
+ (origin (method url-fetch)
+ (uri (string-append "https://fossil-scm.org/home/vpatch?from=" from
+ "&to=" to))
+ (sha256 (base32 hash))
+ (file-name name)))
(package
(name "fossil")
- (version "2.20")
+ (version "2.24")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://www.fossil-scm.org/home/tarball/"
- "210e89a0597f225f49722b096cf5563bf193e920e02a9bd38503a906deacd416"
- "/fossil-src-" version ".tar.gz"))
- ;; XXX: Currently the above hash must be manually updated.
+ "https://fossil-scm.org/home/tarball/version-" version "/fossil-" version ".tar.gz"))
(sha256
- (base32 "08g7img88n2nwcdkpzmg4aqbp2iy40nllgas53502dspm97ym4h8"))
+ (base32 "0k1gjvxbvvs98yspnf7nj6rb0c7yf60savq7jywbkgimd0bkrkcm"))
+ (patch-flags '("-p0"))
+ (patches `(,(fossil-patch "fossil-disable-tests.patch"
+ "8be0372c10510437"
+ "5ad708085a90365f"
+ "1b4svsrz7cr1zi6qfpavj3ddm6dr0966jbgkbvgjz79ljqmpiasf")
+ ,(fossil-patch "fossil-fix-json-test.patch"
+ "fb4e90b662803e47"
+ "17c01c549e73c6b8"
+ "12gjzyxs22g9grv7qbgp9jg133bgcsj74621s05fk82j3fc7z59g")
+ ,(fossil-patch "fossil-comment-utf-tests.patch"
+ "5ad708085a90365f"
+ "fb4e90b662803e47"
+ "05h2mb6g0840yq74x1cdj95jmqb95i75h6g5v0rzqdc994b96cd4")))
(modules '((guix build utils)))
(snippet
'(delete-file-recursively "compat"))))
@@ -3090,7 +3106,7 @@ by rclone usable with git-annex.")
which ;for tests only
ed)) ;ditto
(inputs
- (list openssl zlib sqlite))
+ (list openssl zlib sqlite-next))
(arguments
`(#:configure-flags (list "--with-openssl=auto"
"--disable-internal-sqlite")
@@ -3158,7 +3174,7 @@ be served with a HTTP file server of your choice.")
(define-public gource
(package
(name "gource")
- (version "0.51")
+ (version "0.54")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3166,15 +3182,26 @@ be served with a HTTP file server of your choice.")
"/gource-" version "/gource-" version ".tar.gz"))
(sha256
(base32
- "16p7b1x4r0915w883lp374jcdqqja37fnb7m8vnsfnl2n64gi8qr"))))
+ "1rgsssff5ygafc5svg19p046r4h2q9a3wqqbzrllvkyjcpgwxjqx"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
(list (string-append "--with-boost-libdir="
(assoc-ref %build-inputs "boost")
- "/lib"))))
+ "/lib")
+ "--with-tinyxml")
+ #:disallowed-references (,tzdata-for-tests)
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'unbundle
+ (lambda _
+ (delete-file-recursively "src/tinyxml")))
+ (add-before 'check 'check-setup
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TZDIR" ; for src/test/datetime_tests.cpp
+ (search-input-directory inputs
+ "share/zoneinfo")))))))
(native-inputs
- (list pkg-config))
+ (list pkg-config tzdata-for-tests))
(inputs
(list boost
ftgl
@@ -3183,8 +3210,9 @@ be served with a HTTP file server of your choice.")
glu
libpng
mesa
- pcre
- (sdl-union (list sdl2 sdl2-image))))
+ pcre2
+ (sdl-union (list sdl2 sdl2-image))
+ tinyxml))
(home-page "https://gource.io/")
(synopsis "3D visualisation tool for source control repositories")
(description "@code{gource} provides a software version control