summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm58
1 files changed, 24 insertions, 34 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index e6fbf6e005..6f26f404be 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -39,14 +39,14 @@
(define-public tor
(package
(name "tor")
- (version "0.2.8.9")
+ (version "0.2.9.8")
(source (origin
(method url-fetch)
(uri (string-append "https://dist.torproject.org/tor-"
version ".tar.gz"))
(sha256
(base32
- "05jkvhbgyq81fcmk1xpl3yw97ljj5sg9pngl27zlmgl7p0xjfp1z"))))
+ "0sklgmx4nikcfhqd606kvpwy1l8840w24ikli1xjjx25739k7pgv"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-2))) ; for tests
@@ -54,9 +54,6 @@
`(("zlib" ,zlib)
("openssl" ,openssl)
("libevent" ,libevent)))
-
- ;; TODO: Recommend `torsocks' since `torify' needs it.
-
(home-page "https://www.torproject.org/")
(synopsis "Anonymous network router to improve privacy on the Internet")
(description
@@ -66,7 +63,12 @@ somebody watching your Internet connection from learning what sites you
visit, and it prevents the sites you visit from learning your physical
location. Tor works with many of your existing applications, including
web browsers, instant messaging clients, remote login, and other
-applications based on the TCP protocol.")
+applications based on the TCP protocol.
+
+To @code{torify} applications (to take measures to ensure that an application,
+which has not been designed for use with Tor such as ssh, will use only Tor for
+internet connectivity, and also ensures that there are no leaks from DNS, UDP or
+the application layer) you need to install @code{torsocks}.")
(license bsd-3)))
(define-public torsocks
@@ -138,7 +140,7 @@ networks.")
(define-public onionshare
(package
(name "onionshare")
- (version "0.9")
+ (version "0.9.2")
(source
(origin
(method url-fetch)
@@ -147,8 +149,7 @@ networks.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0pc3xbq379415s0i0y6rz02hay20zbvgra1jmg4mgrl9vbdr8zmw"))
- (patches (search-patches "onionshare-fix-install-paths.patch"))))
+ "02iv7dg15da57gy3zvfchnwwpr21n1gva7mqwpwr958ni2034smk"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -157,25 +158,17 @@ networks.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(onionshare (string-append out "/share/onionshare")))
- (substitute*
- "install/pyinstaller.spec"
- ;; inform onionshare where the 'resources' files are installed
- (("../resources") onionshare))
- (substitute*
- "onionshare/strings.py"
+ (substitute* "onionshare/strings.py"
;; correct the locale directory
(("helpers.get_resource_path\\('locale'\\)")
(string-append "'" onionshare "/locale'")))
- (substitute*
- "onionshare/helpers.py"
+ (substitute* "onionshare/helpers.py"
;; correct the location of version.txt
- (("/usr") out)
(("get_resource_path\\('version.txt'\\)")
(string-append "'" onionshare "/version.txt'"))
(("get_resource_path\\('wordlist.txt'\\)")
(string-append "'" onionshare "/wordlist.txt'")))
- (substitute*
- "onionshare/web.py"
+ (substitute* "onionshare/web.py"
;; fix the location of the html files
(("helpers.get_resource_path\\('html/denied.html'\\)")
(string-append "'" onionshare "/html/denied.html'"))
@@ -183,36 +176,33 @@ networks.")
(string-append "'" onionshare "/html/404.html'"))
(("helpers.get_resource_path\\('html/index.html'\\)")
(string-append "'" onionshare "/html/index.html'")))
- (substitute*
- "onionshare_gui/file_selection.py"
+ (substitute* "onionshare_gui/file_selection.py"
+ ;; fancy box image in the GUI
(("helpers.get_resource_path\\('images/drop_files.png'\\)")
(string-append "'" onionshare "/images/drop_files.png'")))
- (substitute*
- "onionshare_gui/server_status.py"
+ (substitute* "onionshare_gui/server_status.py"
(("helpers.get_resource_path\\('images/server_stopped.png'\\)")
(string-append "'" onionshare "/images/server_stopped.png'"))
(("helpers.get_resource_path\\('images/server_working.png'\\)")
(string-append "'" onionshare "/images/server_working.png'"))
(("helpers.get_resource_path\\('images/server_started.png'\\)")
(string-append "'" onionshare "/images/server_started.png'")))
- (substitute*
- "onionshare_gui/onionshare_gui.py"
+ (substitute* "onionshare_gui/onionshare_gui.py"
+ ;; for the icon on the GUI
(("helpers.get_resource_path\\('images/logo.png'\\)")
(string-append "'" onionshare "/images/logo.png'")))
- (substitute*
- "install/onionshare.desktop"
- (("/usr") out))
+ (substitute* '("setup.py" "onionshare/helpers.py")
+ (("sys.prefix,") (string-append "'" out "',")))
+ (substitute* "setup.py"
+ ;; for the nautilus plugin
+ (("/usr/share/nautilus") "share/nautilus"))
#t)))
(delete 'check)
(add-before 'strip 'tests
;; After all the patching we run the tests after installing.
;; This is also a known issue:
;; https://github.com/micahflee/onionshare/issues/284
- (lambda _ (zero? (system* "nosetests" "test")))))
- ;; can't compress the egg because it expects to find all the resources
- ;; inside the egg as though it were a folder.
- #:configure-flags '("--single-version-externally-managed" "--root=/")
- ))
+ (lambda _ (zero? (system* "nosetests" "test")))))))
(native-inputs
`(("python-nose" ,python-nose)))
(inputs