summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm37
1 files changed, 24 insertions, 13 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index e498909047..61bbe424e2 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -495,14 +495,14 @@ required structures.")
(define-public libressl
(package
(name "libressl")
- (version "2.7.4")
+ (version "3.0.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://openbsd/LibreSSL/"
"libressl-" version ".tar.gz"))
(sha256
(base32
- "19kxa5i97q7p6rrps9qm0nd8zqhdjvzx02j72400c73cl2nryfhy"))))
+ "13ir2lpxz8y1m151k7lrx306498nzfhwlvgkgv97v5cvywmifyyz"))))
(build-system gnu-build-system)
(arguments
;; Do as if 'getentropy' was missing since older Linux kernels lack it
@@ -537,13 +537,13 @@ netcat implementation that supports TLS.")
(package
(name "python-acme")
;; Remember to update the hash of certbot when updating python-acme.
- (version "1.0.0")
+ (version "1.2.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "acme" version))
(sha256
(base32
- "1hl62dnh8zsipa5azzpy5kwgjgb5vflinhna1fsn7rcchhpz223a"))))
+ "1ar6mjax7cyvq3zgh64yrg485l02dy6zqddxjxg99nlvsi0cfc06"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -594,7 +594,7 @@ netcat implementation that supports TLS.")
(uri (pypi-uri "certbot" version))
(sha256
(base32
- "0aih7sir5byy8ah9lrgzwcaga7hjw98qj8bb1pxzzzqrvcqjvf46"))))
+ "0g1p4nkaid6davjm5qz8lsln92dhjhlv3rrg8hcfpr7qhphbmp4m"))))
(build-system python-build-system)
(arguments
`(,@(substitute-keyword-arguments (package-arguments python-acme)
@@ -842,7 +842,7 @@ then ported to the GNU / Linux environment.")
(define-public mbedtls-apache
(package
(name "mbedtls-apache")
- (version "2.16.4")
+ (version "2.16.5")
(source
(origin
(method url-fetch)
@@ -852,7 +852,7 @@ then ported to the GNU / Linux environment.")
version "-apache.tgz"))
(sha256
(base32
- "1yxj5wahaj87xhdi89zbk78ig77b166h464yrj5gb3lwv8mz6h9l"))))
+ "0kdhwy241xsk4isbadqx6z80m8sf76da5sbmqv8qy11yr37cdd35"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
@@ -895,35 +895,46 @@ coding footprint.")
(source (origin
(method url-fetch)
(uri (string-append
- "https://github.com/lukas2511/dehydrated/releases/download/"
+ "https://github.com/dehydrated-io/dehydrated/releases/download/"
"v" version "/dehydrated-" version ".tar.gz"))
(sha256
(base32
"0dgskgbdd95p13jx6s13p77y15wngb5cm6p4305cf2s54w0bvahh"))))
(build-system trivial-build-system)
(arguments
- `(#:modules ((guix build utils))
+ `(#:modules ((guix build utils)
+ (srfi srfi-26))
#:builder
(begin
- (use-modules (guix build utils))
+ (use-modules (guix build utils)
+ (srfi srfi-26))
(let* ((source (assoc-ref %build-inputs "source"))
(tar (assoc-ref %build-inputs "tar"))
(gz (assoc-ref %build-inputs "gzip"))
(out (assoc-ref %outputs "out"))
(bin (string-append out "/bin"))
- (doc (string-append out "/share/doc/"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version))
+ (man (string-append out "/share/man"))
(bash (in-vicinity (assoc-ref %build-inputs "bash") "bin")))
(setenv "PATH" (string-append gz "/bin"))
(invoke (string-append tar "/bin/tar") "xvf" source)
(chdir (string-append ,name "-" ,version))
+ (copy-recursively "docs" doc)
+ (install-file "LICENSE" doc)
+
+ (mkdir-p man)
+ (rename-file (string-append doc "/man")
+ (string-append man "/man1"))
+ (for-each (cut invoke "gzip" "-9" <>)
+ (find-files man ".*"))
+
(install-file "dehydrated" bin)
- (install-file "LICENSE" (string-append doc ,name "-" ,version))
(with-directory-excursion bin
(patch-shebang "dehydrated" (list bash))
- ;; Do not try to write in the store.
+ ;; Do not try to write to the store.
(substitute* "dehydrated"
(("SCRIPTDIR=\"\\$.*\"") "SCRIPTDIR=~/.dehydrated"))