summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index e0ce6df421..a4129e0899 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -114,13 +114,14 @@
(string-append "--exec-prefix=" out)
(string-append "--mandir=" out "/share/man")))
- #:phases (alist-cons-before
- 'configure 'set-path-to-stty
- (lambda _
- (substitute* "configure"
- (("STTY_BIN=/bin/stty")
- (string-append "STTY_BIN=" (which "stty")))))
- %standard-phases)
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-path-to-stty
+ (lambda _
+ (substitute* "configure"
+ (("STTY_BIN=/bin/stty")
+ (string-append "STTY_BIN=" (which "stty"))))
+ #t)))
#:test-target "test"))
(home-page "http://expect.nist.gov/")