summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm32
1 files changed, 11 insertions, 21 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index f9a3a42e14..61ab96adee 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -43,24 +43,15 @@
(define-public libssh
(package
(name "libssh")
- (version "0.6.3")
+ (version "0.6.5")
(source (origin
(method url-fetch)
- (uri (string-append "https://red.libssh.org/attachments/download/87/libssh-"
- version ".tar.xz"))
+ (uri (string-append
+ "https://red.libssh.org/attachments/download/121/libssh-"
+ version ".tar.xz"))
(sha256
(base32
- "1jyaj9h1iglvn02hrvcchbx8ycjpj8b91h8mi459k7q5jp2xgd9b"))
- (patches
- ;; Apply the patch as discussed at
- ;; <http://lists.gnu.org/archive/html/guix-devel/2014-10/msg00180.html>.
- (list (origin
- (uri
- "http://git.libssh.org/projects/libssh.git/patch/?id=a033b93c616f4a81afc3fc6a017396d507d96c19")
- (method url-fetch)
- (sha256
- (base32
- "16fdkjcnhc6j7qxz9575fzr9044927ws5259yh0xb9yv1q14j0vh")))))))
+ "0b6wyx6bwbb8jpn8x4rhlrdiqwqrwrs0mxjmrnqykm9kw1ijgm8g"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DWITH_GCRYPT=ON")
@@ -68,10 +59,7 @@
;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
#:tests? #f))
(inputs `(("zlib" ,zlib)
- ;; Link against an older gcrypt, because libssh tries to access
- ;; fields of 'gcry_thread_cbs' that are now private:
- ;; src/threads.c:72:26: error: 'struct gcry_thread_cbs' has no member named 'mutex_init'
- ("libgcrypt", libgcrypt-1.5)))
+ ("libgcrypt", libgcrypt)))
(synopsis "SSH client library")
(description
"libssh is a C library implementing the SSHv2 and SSHv1 protocol for
@@ -188,15 +176,17 @@ Additionally, various channel-specific options can be negotiated.")
(define-public guile-ssh
(package
(name "guile-ssh")
- (version "0.7.2")
+ (version "0.8.0")
(source (origin
+ ;; ftp://memory-heap.org/software/guile-ssh/guile-ssh-VERSION.tar.gz
+ ;; exists, but the server appears to be too slow and unreliable.
(method git-fetch)
(uri (git-reference
(url "https://github.com/artyom-poptsov/libguile-ssh.git")
(commit (string-append "v" version))))
(sha256
(base32
- "1wcv10xv7ayrhrg77zyng6flknnlkzhni24nf8x9nic00zha8znk"))))
+ "1ld2khzylaylhqfsfcvbxs95frvm8pkr7dq40ia1wwn9c349fcdv"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-after
@@ -235,7 +225,7 @@ Additionally, various channel-specific options can be negotiated.")
("which" ,which)))
(inputs `(("guile" ,guile-2.0)
("libssh" ,libssh)
- ("libgcrypt" ,libgcrypt-1.5)))
+ ("libgcrypt" ,libgcrypt)))
(synopsis "Guile bindings to libssh")
(description
"Guile-SSH is a library that provides access to the SSH protocol for