summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm37
1 files changed, 33 insertions, 4 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index f5e839fd58..0e61284c50 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -12,7 +12,8 @@
;;; Copyright © 2019 Meiyo Peng <meiyo.peng@gmail.com>
;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2019 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2019, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -403,7 +404,7 @@ history mechanism, job control and a C-like syntax.")
(define-public zsh
(package
(name "zsh")
- (version "5.6.2")
+ (version "5.7.1")
(source (origin
(method url-fetch)
(uri (list (string-append
@@ -414,9 +415,10 @@ history mechanism, job control and a C-like syntax.")
".tar.xz")))
(sha256
(base32
- "17iffliqcj4hv91g0bd2sxsyfcz51mfyh97sp2iyrs2p0mndc2x5"))))
+ "1s3yww0mzgvpc48kp0x868mm3gbna42sbgzya0nknj0x5hn2jq3j"))))
(build-system gnu-build-system)
- (arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre")
+ (arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre"
+ "--enable-maildir-support")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'fix-sh
@@ -826,3 +828,30 @@ Scheme. It provides both the shell interface, as well as a Guile
library for parsing shell scripts. Gash is designed to bootstrap Bash
as part of the Guix bootstrap process.")
(license gpl3+)))
+
+(define-public gash-utils
+ (package
+ (name "gash-utils")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/gash/gash-utils-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ib2p52qmbac5n0s5bys4fiwim461ps546976l1n7pwbs0avh7fk"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)
+ ("gash" ,gash)))
+ (home-page "https://savannah.nongnu.org/projects/gash/")
+ (synopsis "Core POSIX utilities written in Guile Scheme")
+ (description "Gash-Utils provides Scheme implementations of many
+common POSIX utilities (there are about 40 of them, ranging in
+complexity from @command{false} to @command{awk}). The utilities are
+designed to be capable of bootstrapping their standard GNU counterparts.
+Underpinning these utilities are many Scheme interfaces for manipulating
+files and text.")
+ (license gpl3+)))