summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index d85b809ce7..35a96b5754 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -451,7 +452,7 @@ test = { path = \"../libtest\" }
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
- (synopsis "Compiler for the Rust progamming language")
+ (synopsis "Compiler for the Rust programming language")
(description "Rust is a systems programming language that provides memory
safety and thread safety guarantees.")
(home-page "https://www.rust-lang.org")
@@ -616,7 +617,8 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(lambda (file) (delete-manifest-file out file))
'("install.log"
"manifest-rust-docs"
- "manifest-rust-std-x86_64-unknown-linux-gnu"
+ ,(string-append "manifest-rust-std-"
+ (nix-system->gnu-triplet-for-rust))
"manifest-rustc"))
(for-each
(lambda (file) (delete-manifest-file cargo-out file))