summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm80
1 files changed, 36 insertions, 44 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index b974c0340f..5d9c9d3438 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -26,6 +26,7 @@
(define-module (gnu packages radio)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -505,10 +506,10 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
("python-pyzmq" ,python-pyzmq)
("python-scipy" ,python-scipy)
("python-sphinx" ,python-sphinx)
- ("texlive" ,(texlive-union (list texlive-amsfonts/patched
- texlive-latex-amsmath
- ;; TODO: Add newunicodechar.
- texlive-latex-graphics)))
+ ("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
+ texlive-latex-amsmath
+ ;; TODO: Add newunicodechar.
+ texlive-latex-graphics)))
("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -583,8 +584,7 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
(add-before 'check 'set-test-environment
(lambda* (#:key inputs #:allow-other-keys)
(setenv "HOME" "/tmp")
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 &"))
+ (system "Xvfb :1 &")
(setenv "DISPLAY" ":1")
#t))
(replace 'check
@@ -625,7 +625,7 @@ used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
(variable "GRC_BLOCKS_PATH")
(files '("share/gnuradio/grc/blocks")))
(search-path-specification
- (variable "PYTHONPATH")
+ (variable "GUIX_PYTHONPATH")
(files (list (string-append "lib/python"
(version-major+minor
(package-version python))
@@ -715,7 +715,7 @@ to access different radio hardware.")
("doxygen" ,doxygen)
("libtool" ,libtool)
("pkg-config" ,pkg-config)
- ("texlive" ,(texlive-union (list texlive-amsfonts/patched
+ ("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-latex-amsmath
;; TODO: Add newunicodechar.
texlive-latex-graphics)))))
@@ -728,9 +728,7 @@ to access different radio hardware.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "git-version-gen"
(("/bin/sh")
- (string-append (assoc-ref inputs "bash")
- "/bin/bash")))
- #t)))))
+ (search-input-file inputs "/bin/bash"))))))))
(synopsis "DSP primitives for SDR")
(description
"This a C-language library for common DSP (Digital Signal Processing)
@@ -1656,8 +1654,7 @@ methods:
"-lncurses"))
(substitute* "src/libcw/libcw_pa.c"
(("libpulse-simple.so" all)
- (string-append (assoc-ref inputs "pulseaudio")
- "/lib/" all))))))))
+ (search-input-file inputs "/lib/libpulse-simple.so"))))))))
(home-page "http://unixcw.sourceforge.net/")
(synopsis "Morse code library and programs")
(description
@@ -1692,7 +1689,8 @@ intended for people who want to learn receiving and sending morse code.")
("osm-gps-map" ,osm-gps-map)
("pulseaudio" ,pulseaudio)))
(arguments
- `(#:tests? #f ; No test suite
+ `(#:configure-flags '("-DCMAKE_C_FLAGS=-fcommon")
+ #:tests? #f ; No test suite
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-paths
@@ -1790,24 +1788,18 @@ Compatible hardware/software:
(string-append "documentation.path = "
(assoc-ref outputs "out")
"/share/man/man1"))
- (("/usr/include/pulse/")
- (string-append (assoc-ref inputs "pulseaudio")
- "/include/pulse/"))
+ (("/usr/include/pulse")
+ (search-input-directory inputs "/include/pulse"))
(("/usr/include/sndfile\\.h")
- (string-append (assoc-ref inputs "libsndfile")
- "/include/sndfile.h"))
- (("/usr/include/opus/")
- (string-append (assoc-ref inputs "opus")
- "/include/opus/"))
- (("/usr/include/speex/")
- (string-append (assoc-ref inputs "speexdsp")
- "/include/speex/"))
- (("/usr/include/qwt/")
- (string-append (assoc-ref inputs "qwt")
- "/include/qwt/"))
+ (search-input-file inputs "/include/sndfile.h"))
+ (("/usr/include/opus")
+ (search-input-directory inputs "/include/opus"))
+ (("/usr/include/speex")
+ (search-input-directory inputs "/include/speex"))
+ (("/usr/include/qwt")
+ (search-input-directory inputs "/include/qwt"))
(("\\$\\$OUT_PWD/include/neaacdec\\.h")
- (string-append (assoc-ref inputs "faad2")
- "/include/neaacdec.h")))))
+ (search-input-file inputs "/include/neaacdec.h")))))
(replace 'configure
(lambda _
(invoke "qmake"))))))
@@ -2094,20 +2086,20 @@ voice formats.")
(arguments
`(#:tests? #f ; No test suite.
#:configure-flags
- (list (string-append "-DAPT_DIR="
- (assoc-ref %build-inputs "aptdec"))
- (string-append "-DDAB_DIR="
- (assoc-ref %build-inputs "libdab"))
- (string-append "-DDSDCC_DIR="
- (assoc-ref %build-inputs "dsdcc"))
- (string-append "-DMBE_DIR="
- (assoc-ref %build-inputs "mbelib"))
- (string-append "-DSERIALDV_DIR="
- (assoc-ref %build-inputs "serialdv"))
- (string-append "-DSGP4_DIR="
- (assoc-ref %build-inputs "sgp4"))
- (string-append "-DSOAPYSDR_DIR="
- (assoc-ref %build-inputs "soapysdr")))))
+ ,#~(list (string-append "-DAPT_DIR="
+ #$(this-package-input "aptdec"))
+ (string-append "-DDAB_DIR="
+ #$(this-package-input "libdab"))
+ (string-append "-DDSDCC_DIR="
+ #$(this-package-input "dsdcc"))
+ (string-append "-DMBE_DIR="
+ #$(this-package-input "mbelib"))
+ (string-append "-DSERIALDV_DIR="
+ #$(this-package-input "serialdv"))
+ (string-append "-DSGP4_DIR="
+ #$(this-package-input "sgp4"))
+ (string-append "-DSOAPYSDR_DIR="
+ #$(this-package-input "soapysdr")))))
(home-page "https://github.com/f4exb/sdrangel/wiki")
(synopsis "Software defined radio")
(description