summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:33:09 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:37:26 +0000
commite486b2b674badc80627b11077b7df2ac1cab92d8 (patch)
tree5909547a69c4b185b878c8f0fe8152f1c01fef04 /gnu/packages/radio.scm
parent0df1eb029efe5ebe3f02e36fa650cae4aaba89ec (diff)
parent88badc074a5dbebf80115918cf6c0009075154d2 (diff)
downloadguix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar
guix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm24
1 files changed, 8 insertions, 16 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 2b578d62b5..5d9c9d3438 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -837,7 +837,7 @@ satellites.")
(define-public gqrx
(package
(name "gqrx")
- (version "2.14.4")
+ (version "2.14.6")
(source
(origin
(method git-fetch)
@@ -846,7 +846,7 @@ satellites.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0m4ncydihz4n4i80c252vk3c5v672yab1jv85n6ndn7a92xv3ilq"))))
+ (base32 "0gz875fbg0ffdi7icm0hqg0dz33hdfszi70b7cax1fcgq5fr1j8c"))))
(build-system qt-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -2037,7 +2037,7 @@ voice formats.")
(define-public sdrangel
(package
(name "sdrangel")
- (version "6.16.1")
+ (version "6.17.1")
(source
(origin
(method git-fetch)
@@ -2046,7 +2046,7 @@ voice formats.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0g9h4cy8k9dqlwkfk4lkk2d2s003bckzskm3vra87ndmgq1nfbzv"))))
+ (base32 "1yraif6dzs5sdskxnj937x613xz3zxnqim5mnk18vj2m0apcaqam"))))
(build-system qt-build-system)
(native-inputs
`(("doxygen" ,doxygen)
@@ -2110,7 +2110,7 @@ various hardware.")
(define-public sdr++
(package
(name "sdr++")
- (version "1.0.3")
+ (version "1.0.4")
(source
(origin
(method git-fetch)
@@ -2119,7 +2119,7 @@ various hardware.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1mplhys07l4bqv3q301ayh35468mg0hpxp5zgrps7gkjyf3v6idr"))))
+ (base32 "1xwbz6yyca6wmzad5ykxw6i0r8jzc7i3jbzq7mhp8caiymd6knw3"))))
(build-system cmake-build-system)
(native-inputs
`(("gcc" ,gcc-10) ; A GCC more recent than version 7 is required.
@@ -2367,7 +2367,7 @@ of devices than RTL-SDR.")
(define-public gnss-sdr
(package
(name "gnss-sdr")
- (version "0.0.14")
+ (version "0.0.15")
(source
(origin
(method git-fetch)
@@ -2376,7 +2376,7 @@ of devices than RTL-SDR.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1kjh9bnf6h9q71bnn8nrwlc80wcnkib97ylzvb102acii4p0fm08"))))
+ (base32 "1m41rnlfr1nrzbg382jfsk5x0by2ym48v3innd2rbc6phd85q223"))))
(build-system cmake-build-system)
(native-inputs
`(("gfortran" ,gfortran)
@@ -2414,14 +2414,6 @@ of devices than RTL-SDR.")
(assoc-ref %build-inputs "googletest-source")))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-tests
- (lambda _
- ;; Some tests fail to compile when the FILESYSTEM package is
- ;; available, so we disable it (and the tests will use Boost
- ;; Filesystem instead).
- (substitute* "CMakeLists.txt"
- (("find_package\\(FILESYSTEM COMPONENTS Final Experimental\\)")
- ""))))
(add-before 'check 'set-home
(lambda _
(setenv "HOME" "/tmp"))))))