summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c42daa106a..2f3219c58e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4765,10 +4765,16 @@ a front-end for C compilers or analysis tools.")
`(("python-cffi" ,python-cffi) ; used at run time
("python-six" ,python-six)))
(arguments
- `(;; FIXME: Tests cannot load libxcb.so.1
+ `(;; FIXME: Tests need more work. See ".travis.yml" in the repository.
#:tests? #f
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-libxcb-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libxcb (assoc-ref inputs "libxcb")))
+ (substitute* '("xcffib/__init__.py")
+ (("^soname = \"") (string-append "soname = \"" libxcb "/lib/")))
+ #t)))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let ((doc (string-append (assoc-ref outputs "out") "/share"