summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 6f3dbbf9f2..bfc6614c6b 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1212,14 +1212,14 @@ none of them have everything that I'd like, so here's one more. It uses
(define-public python-libnacl
(package
(name "python-libnacl")
- (version "1.6.1")
+ (version "1.7.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "libnacl" version))
(sha256
(base32
- "0nv7n8nfswkhl614x5mllrkvaslraa0053q11iylb337cy43vb4v"))))
+ "0srx7i264v4dq9and8y6gpzzhrg8jpxs5iy9ggw4plimfj0rjfdm"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1227,11 +1227,10 @@ none of them have everything that I'd like, so here's one more. It uses
(add-after 'unpack 'locate-libsodium
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "libnacl/__init__.py"
- (("(return ctypes.cdll.LoadLibrary\\(')libsodium.so('\\))"
- _ pre post)
- (let ((libsodium (string-append (assoc-ref inputs "libsodium")
- "/lib/libsodium.so")))
- (string-append pre libsodium post)))))))))
+ (("/usr/local/lib/libsodium.so")
+ (string-append (assoc-ref inputs "libsodium")
+ "/lib/libsodium.so")))
+ #t)))))
(native-inputs
`(("python-pyhamcrest" ,python-pyhamcrest)))
(inputs