summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm28
1 files changed, 18 insertions, 10 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index a28cb31e5c..5ffe7c8999 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -48,12 +48,13 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:))
(define-public php
(package
(name "php")
- (version "7.2.12")
+ (version "7.3.0")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -61,7 +62,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "1qbz2j9kzqxxp0mmx02zavvz20ji7izqdnri25g1mrwyhz60974q"))
+ "1db0lm84hynilrjj3k1s7skp1y2gl4ip1ihr7662i2xgannmq6bx"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -74,7 +75,7 @@
;;"fileinfo/libmagic" ; This is a patched version of libmagic.
'("gd/libgd"
"mbstring/oniguruma"
- "pcre/pcrelib"
+ "pcre/pcre2lib"
"sqlite3/libsqlite"
"xmlrpc/libxmlrpc"
"zip/lib"))
@@ -176,11 +177,6 @@
(substitute* "ext/standard/tests/streams/bug60602.phpt"
(("'ls'") (string-append "'" (which "ls") "'")))
- ;; The expected output is slightly different from what is given,
- ;; in a section that's not related to the actual test
- (substitute* "sapi/cli/tests/upload_2G.phpt"
- (("Test\\\\n") "Test\n\n"))
-
;; Drop tests that are known to fail.
(for-each delete-file
'("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.
@@ -291,7 +287,10 @@
"ext/ldap/tests/ldap_set_option_error.phpt"
;; Sometimes cannot start the LDAP server.
- "ext/ldap/tests/bug76248.phpt"))
+ "ext/ldap/tests/bug76248.phpt"
+
+ ;; Bug #76909 preg_match difference between 7.3 and < 7.3
+ "ext/pcre/tests/bug76909.phpt"))
;; Skip tests requiring network access.
(setenv "SKIP_ONLINE_TESTS" "1")
@@ -324,7 +323,7 @@
("oniguruma" ,oniguruma-5)
("openldap" ,openldap)
("openssl" ,openssl)
- ("pcre" ,pcre)
+ ("pcre" ,pcre2)
("postgresql" ,postgresql)
("readline" ,readline)
("sqlite" ,sqlite)
@@ -350,3 +349,12 @@ systems, web content management systems and web frameworks." )
license:lgpl2.1+ ; ext/bcmath/libbcmath
license:bsd-2 ; ext/fileinfo/libmagic
license:expat)))) ; ext/date/lib
+
+(define-public php-with-bcmath
+ (package
+ (inherit php)
+ (name "php-with-bcmath")
+ (arguments
+ (substitute-keyword-arguments (package-arguments php)
+ ((#:configure-flags flags)
+ `(cons "--enable-bcmath" ,flags))))))