summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 29c6b07b95..3470fc3cbe 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2699,6 +2699,29 @@ By itself it is not a particularly interesting module by any measure, however
it ties together a family of modern toolchain modules.")
(license (package-license perl))))
+(define-public perl-extutils-depends
+ (package
+ (name "perl-extutils-depends")
+ (version "0.405")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/X/XA/XAOC/"
+ "ExtUtils-Depends-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0b4ab9qmcihsfs2ajhn5qzg7nhazr68v3r0zvb7076smswd41mla"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-number-delta" ,perl-test-number-delta)))
+ (home-page "http://search.cpan.org/dist/ExtUtils-Depends")
+ (synopsis "Easily build XS extensions that depend on XS extensions")
+ (description
+ "This module tries to make it easy to build Perl extensions that use
+functions and typemaps provided by other perl extensions. This means that a
+perl extension is treated like a shared library that provides also a C and an
+XS interface besides the perl one.")
+ (license (package-license perl))))
+
(define-public perl-extutils-helpers
(package
(name "perl-extutils-helpers")