summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch b/gnu/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch
new file mode 100644
index 0000000000..d867d4cabb
--- /dev/null
+++ b/gnu/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch
@@ -0,0 +1,19 @@
+This patches add compatibility for the forthcoming RobotFramework 5.
+
+Taken from: https://github.com/robotframework/SSHLibrary/pull/403.
+diff --git a/src/SSHLibrary/pythonforward.py b/src/SSHLibrary/pythonforward.py
+index 8b85997b7..607985cf4 100644
+--- a/src/SSHLibrary/pythonforward.py
++++ b/src/SSHLibrary/pythonforward.py
+@@ -1,9 +1,9 @@
+ import select
+ import socket
+ import threading
+-from robot.utils import platform
++from robot.utils import PY2, WINDOWS
+ from .logger import logger
+-if platform.PY2 and platform.WINDOWS:
++if PY2 and WINDOWS:
+ import win_inet_pton
+ try:
+ import SocketServer