summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-08 20:51:35 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-09 15:23:35 -0500
commit1a7424957dbe50c68a49145f95955984c4fa118e (patch)
tree2c8a25a8147e9ed45b376ecd8c9fd046b98afe58 /gnu/packages/patches
parent67cb8e90c4e3ba36859e31b375466cddfc4a5230 (diff)
downloadguix-patches-1a7424957dbe50c68a49145f95955984c4fa118e.tar
guix-patches-1a7424957dbe50c68a49145f95955984c4fa118e.tar.gz
gnu: python-robotframework-sshlibrary: Patch for RobotFramework 5 compatibility.
* gnu/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/python-xyz.scm (python-robotframework-sshlibrary): Apply it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch b/gnu/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch
new file mode 100644
index 0000000000..d867d4cabb
--- /dev/null
+++ b/gnu/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch
@@ -0,0 +1,19 @@
+This patches add compatibility for the forthcoming RobotFramework 5.
+
+Taken from: https://github.com/robotframework/SSHLibrary/pull/403.
+diff --git a/src/SSHLibrary/pythonforward.py b/src/SSHLibrary/pythonforward.py
+index 8b85997b7..607985cf4 100644
+--- a/src/SSHLibrary/pythonforward.py
++++ b/src/SSHLibrary/pythonforward.py
+@@ -1,9 +1,9 @@
+ import select
+ import socket
+ import threading
+-from robot.utils import platform
++from robot.utils import PY2, WINDOWS
+ from .logger import logger
+-if platform.PY2 and platform.WINDOWS:
++if PY2 and WINDOWS:
+ import win_inet_pton
+ try:
+ import SocketServer