summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/quagga-reproducible-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/quagga-reproducible-build.patch')
-rw-r--r--gnu/packages/patches/quagga-reproducible-build.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/quagga-reproducible-build.patch b/gnu/packages/patches/quagga-reproducible-build.patch
new file mode 100644
index 0000000000..80efe4bf62
--- /dev/null
+++ b/gnu/packages/patches/quagga-reproducible-build.patch
@@ -0,0 +1,22 @@
+Make sure, that vtysh_cmd.c is deterministically generated.
+
+--- a/vtysh/extract.pl.in 2017-03-10 13:55:06.000000000 +0100
++++ b/vtysh/extract.pl.in 2017-06-24 00:51:56.460000000 +0200
+@@ -214,7 +214,7 @@
+ }
+
+ # Output DEFSH
+-foreach (keys %live) {
++foreach (sort keys %live) {
+ my ($proto);
+ my ($key);
+ $key = $live{$_};
+@@ -229,7 +229,7 @@
+ {
+ EOF
+
+-foreach (keys %odefun) {
++foreach (sort keys %odefun) {
+ my ($node, $str) = (split (/,/));
+ $cmd = $ocmd{$_};
+ $cmd =~ s/_cmd/_cmd_vtysh/;