summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-3-search-paths.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-3-search-paths.patch')
-rw-r--r--gnu/packages/patches/python-3-search-paths.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-3-search-paths.patch b/gnu/packages/patches/python-3-search-paths.patch
new file mode 100644
index 0000000000..547feae1b9
--- /dev/null
+++ b/gnu/packages/patches/python-3-search-paths.patch
@@ -0,0 +1,19 @@
+Make sure the build system honors CPATH and LIBRARY_PATH when looking for
+headers and libraries.
+
+--- setup.py 2015-10-07 23:32:58.891329173 +0200
++++ setup.py 2015-10-07 23:46:29.653349924 +0200
+@@ -507,11 +507,8 @@ class PyBuildExt(build_ext):
+ # if a file is found in one of those directories, it can
+ # be assumed that no additional -I,-L directives are needed.
+ if not cross_compiling:
+- lib_dirs = self.compiler.library_dirs + [
+- '/lib64', '/usr/lib64',
+- '/lib', '/usr/lib',
+- ]
+- inc_dirs = self.compiler.include_dirs + ['/usr/include']
++ lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
++ inc_dirs = os.getenv('CPATH', '').split(os.pathsep)
+ else:
+ lib_dirs = self.compiler.library_dirs[:]
+ inc_dirs = self.compiler.include_dirs[:]