summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/pybugz-stty.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/pybugz-stty.patch')
-rw-r--r--gnu/packages/patches/pybugz-stty.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/pybugz-stty.patch b/gnu/packages/patches/pybugz-stty.patch
new file mode 100644
index 0000000000..4453e9d027
--- /dev/null
+++ b/gnu/packages/patches/pybugz-stty.patch
@@ -0,0 +1,19 @@
+Gracefully deal with 'stty size' failures.
+Submitted upstream.
+
+--- pybugz-0.6.11/bugz.py 2006-09-02 14:35:37.000000000 +0200
++++ pybugz-0.6.11/bugz.py 2014-05-05 15:17:03.000000000 +0200
+@@ -288,7 +288,12 @@ def get_cols():
+ stty = which('stty')
+ if stty:
+ row_cols = commands.getoutput("%s size" % stty)
+- rows, cols = map(int, row_cols.split())
++ try:
++ rows, cols = map(int, row_cols.split())
++ except:
++ # In some cases 'stty size' will just fail with
++ # "Inappropriate ioctl for device".
++ cols = DEFAULT_NUM_COLS
+ return cols
+ else:
+ return DEFAULT_NUM_COLS