summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/openbabel-fix-crash-on-nwchem-output.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/openbabel-fix-crash-on-nwchem-output.patch')
-rw-r--r--gnu/packages/patches/openbabel-fix-crash-on-nwchem-output.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/patches/openbabel-fix-crash-on-nwchem-output.patch b/gnu/packages/patches/openbabel-fix-crash-on-nwchem-output.patch
deleted file mode 100644
index 879df026a1..0000000000
--- a/gnu/packages/patches/openbabel-fix-crash-on-nwchem-output.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 52cea818bf68f8a2d3c48d55d00c2f8b7da25e4c Mon Sep 17 00:00:00 2001
-From: Daniel Hogan <daniel.hogan@usask.ca>
-Date: Tue, 28 Mar 2017 22:21:18 -0600
-Subject: [PATCH] Remove delete statement.
-
-When from_scratch is true, coordinates is not allocated. A separate if
-statement was added to handle the case when from_scratch is true that
-does not try to free coordinates.
----
- src/formats/nwchemformat.cpp | 9 ++++++---
- 1 file changed, 6 insertions(+), 3 deletions(-)
-
-diff --git a/src/formats/nwchemformat.cpp b/src/formats/nwchemformat.cpp
-index 6f625ad5b..79298555f 100644
---- a/src/formats/nwchemformat.cpp
-+++ b/src/formats/nwchemformat.cpp
-@@ -232,11 +232,14 @@ static const char* OPTIMIZATION_END_PATTERN = " Optimization converged";
- break;
- tokenize(vs,buffer);
- }
-- if ((from_scratch)||(i != natoms))
-- {
-+ if (from_scratch)
-+ {
-+ return;
-+ }
-+ if (i != natoms) {
- delete[] coordinates;
- return;
-- }
-+ }
- molecule->AddConformer(coordinates);
- }
-