summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mercurial-hg-extension-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/mercurial-hg-extension-path.patch')
-rw-r--r--gnu/packages/patches/mercurial-hg-extension-path.patch14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/patches/mercurial-hg-extension-path.patch b/gnu/packages/patches/mercurial-hg-extension-path.patch
index d1073dd01c..8b9d185a89 100644
--- a/gnu/packages/patches/mercurial-hg-extension-path.patch
+++ b/gnu/packages/patches/mercurial-hg-extension-path.patch
@@ -7,15 +7,7 @@ will get this into Mercurial proper.
diff --git a/mercurial/extensions.py b/mercurial/extensions.py
--- a/mercurial/extensions.py
+++ b/mercurial/extensions.py
-@@ -13,6 +13,7 @@
- import imp
- import inspect
- import os
-+import sys
-
- from .i18n import (
- _,
-@@ -108,6 +109,11 @@
+@@ -103,6 +103,11 @@
def _importh(name):
"""import and return the <name> module"""
@@ -24,6 +16,6 @@ diff --git a/mercurial/extensions.py b/mercurial/extensions.py
+ if extension_path is not None:
+ for path in extension_path:
+ sys.path.append(path)
- mod = __import__(pycompat.sysstr(name))
- components = name.split(b'.')
+ mod = __import__(name)
+ components = name.split('.')
for comp in components[1:]: