summaryrefslogtreecommitdiff
path: root/gnu/packages/parallel.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/parallel.scm')
-rw-r--r--gnu/packages/parallel.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 4fc2c9afb4..98721fe1ff 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -32,6 +32,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module ((guix utils) #:select (target-64bit?))
#:use-module (guix packages)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
@@ -158,7 +159,11 @@ and they are executed on lists of files, hosts, users or other items.")
(string-append "--with-freeipmi=" (assoc-ref %build-inputs "freeipmi"))
(string-append "--with-hwloc=" (assoc-ref %build-inputs "hwloc"))
(string-append "--with-json=" (assoc-ref %build-inputs "json-c"))
- (string-append "--with-munge=" (assoc-ref %build-inputs "munge")))
+ (string-append "--with-munge=" (assoc-ref %build-inputs "munge"))
+
+ ;; 32-bit support is marked as deprecated and needs to be
+ ;; explicitly enabled.
+ ,@(if (target-64bit?) '() '("--enable-deprecated")))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'autoconf