summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7a03036b67..de0308bb0a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -428,15 +428,17 @@ LP/MIP solver is included in the package.")
(define-public 4ti2
(package
(name "4ti2")
- (version "1.6.7")
+ (version "1.6.9")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://www.4ti2.de/version_" version
- "/4ti2-" version ".tar.gz"))
- (sha256
- (base32
- "1frix3rnm9ffr93alqzw4cavxbfpf524l8rfbmcpyhwd3n1km0yl"))))
+ (method url-fetch)
+ (uri (string-append "https://github.com/4ti2/4ti2/releases/download/"
+ "Release_"
+ (string-map (lambda (c) (if (char=? c #\.) #\_ c))
+ version)
+ "/4ti2-" version ".tar.gz"))
+ (sha256
+ (base32 "0rj92x6p9m3la5gasjbj7sa569im527ffmka5y2sv1amgd3fflrh"))))
(build-system gnu-build-system)
(native-inputs
`(("which" ,(@ (gnu packages base) which)))) ; for the tests
@@ -2956,6 +2958,7 @@ parts of it.")
#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"SHELL=bash"
+ "MAKE_NB_JOBS=0" ;use jobserver for submakes
;; Build the library for all supported CPUs. This allows
;; switching CPU targets at runtime with the environment variable
;; OPENBLAS_CORETYPE=<type>, where "type" is a supported CPU type.