summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index df4d39f900..232ef40b9c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1183,7 +1183,7 @@ extremely large and complex data collections.")
(define-public hdf5-1.10
(package/inherit hdf5-1.8
- (version "1.10.6")
+ (version "1.10.7")
(source
(origin
(method url-fetch)
@@ -1197,7 +1197,7 @@ extremely large and complex data collections.")
(take (string-split version #\.) 2))
"/src/hdf5-" version ".tar.bz2")))
(sha256
- (base32 "1gf38x51128hn00744358w27xgzjk0ff4wra4yxh2lk804ck1mh9"))
+ (base32 "0pm5xxry55i0h7wmvc7svzdaa90rnk7h78rrjmnlkz2ygsn8y082"))
(patches (search-patches "hdf5-config-date.patch"))))))
(define-public hdf5
@@ -3862,7 +3862,7 @@ Fresnel integrals, and similar related functions as well.")
(define-public suitesparse
(package
(name "suitesparse")
- (version "5.7.1")
+ (version "5.8.1")
(source
(origin
(method git-fetch)
@@ -3872,7 +3872,7 @@ Fresnel integrals, and similar related functions as well.")
(file-name (git-file-name name version))
(sha256
(base32
- "174p3l78kv9gaa0i5hflyai2ydwnjzh34k9938sl4aa3li0543s8"))
+ "0qjlyfxs8s48rs63c2fzspisgq1kk4bwkgnhmh125hgkdhrq2w1c"))
(patches (search-patches "suitesparse-mongoose-cmake.patch"))
(modules '((guix build utils)))
(snippet
@@ -3885,7 +3885,6 @@ Fresnel integrals, and similar related functions as well.")
'(#:tests? #f ;no "check" target
#:make-flags
(list "CC=gcc"
- "BLAS=-lblas"
"TBB=-ltbb"
"MY_METIS_LIB=-lmetis"
;; Flags for cmake (required to build GraphBLAS and Mongoose)
@@ -3907,6 +3906,8 @@ Fresnel integrals, and similar related functions as well.")
(inputs
`(("tbb" ,tbb)
("lapack" ,lapack)
+ ("gmp" ,gmp)
+ ("mpfr" ,mpfr)
("metis" ,metis)))
(native-inputs
`(("cmake" ,cmake-minimal)
@@ -5764,10 +5765,10 @@ compiled against the nauty library.")
"1j5aji1g2vmdvc0gqz45n2ll2l2f6czca04wiyfl5g3sm3a6vhvb"))))
(build-system gnu-build-system)
(native-inputs
- `(("m4", m4)))
+ `(("m4" ,m4)))
(inputs
`(("glpk" ,glpk)
- ("gmp", gmp)))
+ ("gmp" ,gmp)))
(home-page "https://www.bugseng.com/parma-polyhedra-library")
(synopsis
"Parma Polyhedra Library for computations with polyhedra")