summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index a0999cb477..51b2cb3267 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2021, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Mark H Weaver <mhw@netris.org>
@@ -706,6 +706,14 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; doesn't try to link using libtool, and thus fails
;; because of a missing -ldl. Work around that.
`(list "LDFLAGS=-ldl" "--enable-mini-gmp"
+
+ ;; Guile does an LTO build by default, but in 3.0.9 it
+ ;; wrongfully picks 'ar' instead of 'gcc-ar', so work around
+ ;; it (see <https://issues.guix.gnu.org/61086>).
+ ,@(if (version-prefix? "3.0" (package-version guile))
+ '("AR=gcc-ar" "RANLIB=gcc-ranlib")
+ '())
+
,@(if (hurd-target?)
'("--disable-jit")
'())))