summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm30
1 files changed, 27 insertions, 3 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 732ffc0823..0315740bcd 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -48,7 +48,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages xml))
-(define-public llvm
+(define-public llvm-8
(package
(name "llvm")
(version "8.0.0")
@@ -99,6 +99,8 @@ languages is in development. The compiler infrastructure includes mirror sets
of programming tools as well as libraries with equivalent functionality.")
(license license:ncsa)))
+(define-public llvm llvm-8)
+
(define* (clang-runtime-from-llvm llvm hash
#:optional (patches '()))
(package
@@ -371,6 +373,28 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
"0svk1f70hvpwrjp6x5i9kqwrqwxnmcrw5s7f4cxyd100mdd12k08"
#:patches '("clang-7.0-libc-search-path.patch")))
+(define-public llvm-7
+ (package
+ (inherit llvm)
+ (version "7.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://llvm.org/releases/"
+ version "/llvm-" version ".src.tar.xz"))
+ (sha256
+ (base32
+ "16s196wqzdw4pmri15hadzqgdi926zln3an2viwyq0kini6zr3d3"))))))
+
+(define-public clang-runtime-7
+ (clang-runtime-from-llvm
+ llvm-7
+ "065ybd8fsc4h2hikbdyricj6pyv4r7r7kpcikhb2y5zf370xybkq"))
+
+(define-public clang-7
+ (clang-from-llvm llvm-7 clang-runtime
+ "067lwggnbg0w1dfrps790r5l6k8n5zwhlsw7zb6zvmfpwpfn4nx4"
+ #:patches '("clang-7.0-libc-search-path.patch")))
+
(define-public llvm-6
(package
(inherit llvm)
@@ -542,9 +566,9 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
(inputs
`(("llvm"
,(package
- (inherit llvm)
+ (inherit llvm-7)
(source (origin
- (inherit (package-source llvm))
+ (inherit (package-source llvm-7))
(patches
(list
(origin