summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 58cc421ad7..b01ded87ad 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -903,7 +903,7 @@ the HTML documentation of TXR.")
(define-public txr
(package
(name "txr")
- (version "266")
+ (version "268")
(source
(origin
(method git-fetch)
@@ -912,7 +912,7 @@ the HTML documentation of TXR.")
(commit (string-append "txr-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1k9mj3zaxdsylgnb8g6cq0cmp6420x7fp3nnsqdmds4gh8ib95wn"))))
+ (base32 "0q97qddbgk9356gx4xp8iip4pwj3ln03dvjfgrny76f3wmmiwsw6"))))
(build-system gnu-build-system)
(native-inputs
;; Required to build the documentation.
@@ -957,10 +957,7 @@ the HTML documentation of TXR.")
(lambda _
(substitute* (list "tests/017/realpath.tl"
"tests/017/realpath.expected")
- (("/usr/bin") "/"))
- (substitute* "tests/018/path-test.tl"
- (("/bin") (dirname (which "sh"))))
- #t))
+ (("/usr/bin") "/"))))
(replace 'configure
;; ./configure is a hand-written script that can't handle standard
;; autotools arguments like CONFIG_SHELL.