summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7793bf4d7c..2bf7b4bee9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5062,14 +5062,7 @@ under OpenGL graphics workloads.")
(string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'kernel-headers-are-system-headers
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((kernel-headers (assoc-ref inputs "kernel-headers")))
- ;; Make sure the kernel headers are treated as system headers
- ;; to suppress a conflict between "util.h" and <linux/fs.h>.
- (setenv "C_INCLUDE_PATH" (string-append kernel-headers "/include"))
- #t))))))
+ (delete 'configure))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs