summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 0 insertions, 21 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 06ef1fa220..7793bf4d7c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -684,27 +684,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
#t))
(replace 'configure
(lambda* (#:key inputs native-inputs target #:allow-other-keys)
- ;; On AArch64 (at least), we need to remove glibc headers from
- ;; CPATH (they are still available as "system headers"), so that
- ;; the kernel can override uint64_t. See
- ;; <https://bugs.gnu.org/37593>. This is also true when
- ;; cross-compiling, except in that case, cross-libc must be
- ;; removed from CROSS_CPATH.
- (let ((var ,(if (%current-target-system)
- "CROSS_CPATH"
- "CPATH"))
- (libc ,(if (%current-target-system)
- "cross-libc"
- "libc")))
- (setenv var
- (string-join
- (remove
- (cut string-prefix? (assoc-ref inputs libc) <>)
- (string-split (getenv var) #\:))
- ":"))
- (format #t "environment variable `~a' changed to `~a'~%"
- var (getenv var)))
-
;; Avoid introducing timestamps
(setenv "KCONFIG_NOTIMESTAMP" "1")
(setenv "KBUILD_BUILD_TIMESTAMP" (getenv "SOURCE_DATE_EPOCH"))