summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm25
1 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index bb5c25014e..0c62fd9dba 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -89,13 +89,6 @@
("kiconthemes" ,kiconthemes)
("knewstuff" ,knewstuff)
("qtbase" ,qtbase)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://cgit.kde.org/grantleetheme.git")
(synopsis "Library providing Grantlee theme support")
(description "This library provides Grantlee theme support.")
@@ -521,13 +514,7 @@ different notification systems.")
(build-system qt-build-system)
(arguments
`(#:configure-flags '("-DBUILD_TESTING=ON")
- #:tests? #f ; tests fail hard in our build environment
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
+ #:tests? #f)) ; tests fail hard in our build environment
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("kdoctools" ,kdoctools)
@@ -644,7 +631,7 @@ Python, PHP, and Perl.")
"/src/libkdegames-" version ".tar.xz"))
(sha256
(base32 "12dvkmjgbi8dp9y55zmx1pw3zr2i374c4vn3mfn9r31bf06dr701"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
@@ -674,14 +661,6 @@ Python, PHP, and Perl.")
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
("qtsvg" ,qtsvg)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://games.kde.org/")
(synopsis "Runtime library for kdegames")
(description "Runtime library for kdegames")