summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-23 21:13:42 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-28 13:03:08 +0100
commitcd165d105a35da9094b70d0e5d5320a4a6ac8c0d (patch)
treea4ab3240d7e81a0e324b880094a8e88a70d5e6c4 /gnu/packages/kde.scm
parent8377512e0c36146f55bde044e2f9b004c7482236 (diff)
downloadguix-patches-cd165d105a35da9094b70d0e5d5320a4a6ac8c0d.tar
guix-patches-cd165d105a35da9094b70d0e5d5320a4a6ac8c0d.tar.gz
gnu: Cleanup KDE packages to use the update qt-build-system.
* gnu/packages/kde.scm (grantleetheme): [arguments] Remove. (kdeconnect)[arguments]<phases>{check-setup}: Remove. libkdegames: Use qt-build-system. [arguments]: Remove. * gnu/packages/kde-frameworks.scm (kguiaddons, kitemmodels, kitemviews, kplotting, sonnet, kcompletion, kcrash, kdesignerplugin, kglobalaccel, kparts, ktextwidgets, khtml, kmediaplayer): Use qt-build-system. [arguments]: Remove. (kpeople): Use qt-build-system. [arguments]<phases>: Remove. (kconfigwidgets, kwidgetsaddons) Use qt-build-system. [arguments]<phases>{check-setup}: Remove. * gnu/packages/kde-plasma.scm (kdecoration) Use qt-build-system. [arguments]: Remove. (libkscreen): Use qt-build-system. [arguments]<phases>: Remove. (libksysguard): Use qt-build-system. [arguments]<phases>{check-setup}: Remove. * gnu/packages/kde-utils.scm (kronometer, rsibreak): [arguments] Remove.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm25
1 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index bb5c25014e..0c62fd9dba 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -89,13 +89,6 @@
("kiconthemes" ,kiconthemes)
("knewstuff" ,knewstuff)
("qtbase" ,qtbase)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://cgit.kde.org/grantleetheme.git")
(synopsis "Library providing Grantlee theme support")
(description "This library provides Grantlee theme support.")
@@ -521,13 +514,7 @@ different notification systems.")
(build-system qt-build-system)
(arguments
`(#:configure-flags '("-DBUILD_TESTING=ON")
- #:tests? #f ; tests fail hard in our build environment
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
+ #:tests? #f)) ; tests fail hard in our build environment
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("kdoctools" ,kdoctools)
@@ -644,7 +631,7 @@ Python, PHP, and Perl.")
"/src/libkdegames-" version ".tar.xz"))
(sha256
(base32 "12dvkmjgbi8dp9y55zmx1pw3zr2i374c4vn3mfn9r31bf06dr701"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
@@ -674,14 +661,6 @@ Python, PHP, and Perl.")
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
("qtsvg" ,qtsvg)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://games.kde.org/")
(synopsis "Runtime library for kdegames")
(description "Runtime library for kdegames")