summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index ab3497700a..9e0e41c844 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -216,6 +216,36 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
and printing JSON documents.")
(license license:expat)))
+(define-public julia-mbedtls
+ (package
+ (name "julia-mbedtls")
+ (version "1.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaLang/MbedTLS.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zjzf2r57l24n3k0gcqkvx3izwn5827iv9ak0lqix0aa5967wvfb"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'disable-network-tests
+ ;; Tries to connect to httpbin.org
+ (lambda _
+ (substitute* "test/runtests.jl"
+ (("testhost =") "return #"))
+ #t)))))
+ (propagated-inputs `(("julia-mbedtls-jll" ,julia-mbedtls-jll)))
+ (home-page "https://github.com/JuliaLang/MbedTLS.jl")
+ (synopsis "Apache's mbed TLS library wrapper")
+ (description "@code{MbedTLS.jl} provides a wrapper around the @code{mbed
+TLS} and cryptography C libary for Julia.")
+ (license license:expat)))
+
(define-public julia-mbedtls-jll
(package
(name "julia-mbedtls-jll")