summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 32602f3f1b..4cfe09d031 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -32,6 +32,7 @@
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
@@ -825,6 +826,44 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
(description "This package provides a wrapper for the libgcrypt library.")
(license license:expat)))
+(define-public julia-libglvnd-jll
+ (package
+ (name "julia-libglvnd-jll")
+ (version "1.3.0+2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Libglvnd_jll.jl")
+ (commit (string-append "Libglvnd-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lrppqj836saryqxj9xrqn0cih513qhijkhgqdww5azw8w917d3w"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Libglvnd\"")
+ (string-append "\"" (assoc-ref inputs "libglvnd") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libglvnd" ,libglvnd)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-xorg-libx11-jll" ,julia-xorg-libx11-jll)
+ ("julia-xorg-libxext-jll" ,julia-xorg-libxext-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Libglvnd_jll.jl")
+ (synopsis "Libglvnd library wrappers")
+ (description "This package provides a wrapper for the libglvnd library.")
+ (license license:expat)))
+
(define-public julia-libgpg-error-jll
(package
(name "julia-libgpg-error-jll")