summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 9c5566f819..3293f27546 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -212,6 +212,7 @@ JNI.")
`(#:tests? #f ; no "check" target
#:phases
(modify-phases %standard-phases
+ (delete 'bootstrap)
(delete 'configure)
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
@@ -226,6 +227,11 @@ JNI.")
(string-append (assoc-ref inputs "jamvm")
"/lib/rt.jar"))
+ ;; Ant complains if this file doesn't exist.
+ (setenv "HOME" "/tmp")
+ (with-output-to-file "/tmp/.ant.properties"
+ (lambda _ (display "")))
+
;; Use jikes instead of javac for <javac ...> tags in build.xml
(setenv "ANT_OPTS" "-Dbuild.compiler=jikes")
@@ -233,6 +239,11 @@ JNI.")
;; interesting, so we silence them.
(setenv "$BOOTJAVAC_OPTS" "-nowarn")
+ ;; Without these JamVM options the build may freeze.
+ (substitute* "bootstrap.sh"
+ (("^\"\\$\\{JAVACMD\\}\" " m)
+ (string-append m "-Xnocompact -Xnoinlining ")))
+
;; Disable tests because we are bootstrapping and thus don't have
;; any of the dependencies required to build and run the tests.
(substitute* "build.xml"