summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index ae69cfe3a1..e4d4e56388 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -257,7 +257,7 @@ the C implementation.")
(define-public ghc-cryptonite
(package
(name "ghc-cryptonite")
- (version "0.20")
+ (version "0.25")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -265,10 +265,11 @@ the C implementation.")
version ".tar.gz"))
(sha256
(base32
- "0m63np0affci7ba9mrkvw2flzxn0s2mk930xldc4dwijw32gl6r6"))))
+ "131wbbdr5yavs5k1ah9sz6fqx1ffyvaxf66pwjzsfc47mwc1mgl9"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-memory" ,ghc-memory)
+ `(("ghc-basement" ,ghc-basement)
+ ("ghc-memory" ,ghc-memory)
("ghc-byteable" ,ghc-byteable)))
(native-inputs
`(("ghc-tasty" ,ghc-tasty)