summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index ae5fca513a..25077e4f75 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -288,6 +288,18 @@ without requiring the source code to be rewritten.")
(max-silent-time . 36000))))) ;10 hours (needed on ARM
; when heavily loaded)
+(define-public guile-2.2.5
+ (package
+ (inherit guile-2.2)
+ (version "2.2.5")
+ (source (origin
+ (inherit (package-source guile-2.2))
+ (uri (string-append "mirror://gnu/guile/guile-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "19w5ws1jvs01dpv756qv2cgs37rsnwq1f4f07mj0wra35pqp6c7w"))))))
+
(define-public guile-next
;; This is the upcoming Guile 3.0, with JIT support.
(let ((commit "6f3357b0df64c4be17e72079864c09a542f1c779")