summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm19
1 files changed, 3 insertions, 16 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b69fa372d9..05e5165d3f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -966,11 +966,7 @@ application suites.")
("fribidi" ,fribidi)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
- ;; SVG support is optional and requires librsvg, which pulls in rust.
- ;; Rust is not supported well on every architecture yet.
- ("gdk-pixbuf" ,(if (target-x86-64?)
- librsvg
- gdk-pixbuf))
+ ("gdk-pixbuf" ,(librsvg-for-system))
("glib" ,glib)
("libcloudproviders" ,libcloudproviders-minimal)
("libepoxy" ,libepoxy)
@@ -1045,19 +1041,10 @@ application suites.")
(("notify no-gtk-init object objects-finalize papersize rbtree")
"no-gtk-init papersize rbtree")
(("stylecontext templates textbuffer textiter treemodel treepath")
- "stylecontext textbuffer textiter treemodel treepath")
- ;; The ‘icontheme’ test needs SVG support.
- ,@(if (not (target-x86-64?))
- '((("floating focus gestures grid gtkmenu icontheme keyhash listbox")
- "floating focus gestures grid gtkmenu keyhash listbox"))
- '()))
+ "stylecontext textbuffer textiter treemodel treepath"))
(substitute* "testsuite/a11y/Makefile.in"
(("accessibility-dump tree-performance text children derive")
- "tree-performance text children derive")
- ,@(if (not (target-x86-64?))
- '((("value misc tree-relationships util")
- "value misc util"))
- '()))
+ "tree-performance text children derive"))
(substitute* "testsuite/reftests/Makefile.in"
(("TEST_PROGS = gtk-reftest")
"TEST_PROGS = "))