summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index eb3fd1d583..72c96655bc 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -62,6 +62,7 @@
(define-public graphviz
(package
(name "graphviz")
+ (replacement graphviz/fixed)
(version "2.42.3")
(source (origin
(method url-fetch)
@@ -126,6 +127,15 @@ software engineering, database and web design, machine learning, and in visual
interfaces for other technical domains.")
(license license:epl1.0)))
+(define-public graphviz/fixed
+ (hidden-package
+ (package
+ (inherit graphviz)
+ (source (origin
+ (inherit (package-source graphviz))
+ (patches (append (search-patches "graphviz-CVE-2020-18032.patch")
+ (origin-patches (package-source graphviz)))))))))
+
;; Older Graphviz needed for pygraphviz. See
;; https://github.com/pygraphviz/pygraphviz/issues/175
(define-public graphviz-2.38