summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 8091afaf0a..e09981dda0 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -16,7 +16,7 @@
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
@@ -330,7 +330,7 @@ many more.")
(define-public ilmbase
(package
(name "ilmbase")
- (version "2.4.0")
+ (version "2.4.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -339,7 +339,7 @@ many more.")
(file-name (git-file-name "ilmbase" version))
(sha256
(base32
- "0g3rz11cvb7gnphp2np9z7bfl7v4dprq4w5hnsvx7yrasgsdyn8s"))
+ "020gyl8zv83ag6gbcchmqiyx9rh2jca7j8n52zx1gk4rck7kwc01"))
(patches (search-patches "ilmbase-fix-tests.patch"
"ilmbase-openexr-pkg-config.patch"))))
(build-system cmake-build-system)
@@ -854,7 +854,7 @@ exec -a \"$0\" ~a/.brdf-real~%"
("glew" ,glew)
("freeglut" ,freeglut)
("zlib" ,zlib)))
- (home-page "http://www.disneyanimation.com/technology/brdf.html")
+ (home-page "https://www.disneyanimation.com/technology/brdf.html")
(synopsis
"Analyze bidirectional reflectance distribution functions (BRDFs)")
(description
@@ -1061,7 +1061,10 @@ requirements.")
(native-inputs
`(("xorg-server" ,xorg-server-for-tests)))
(inputs
- `(("glew" ,glew)
+ `(;; The test suite fails when using Mesa 19.3.2, so we provide this newer
+ ;; version. Remove this input when the 'mesa' package is updated.
+ ("mesa" ,mesa-19.3.3)
+ ("glew" ,glew)
("libxrandr" ,libxrandr)
("libxcursor" ,libxcursor)
("libxinerama" ,libxinerama)