summaryrefslogtreecommitdiff
path: root/gnu/packages/gps.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gps.scm')
-rw-r--r--gnu/packages/gps.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index fdb64f0902..7ee1fc871d 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -67,6 +68,9 @@
(modules '((guix build utils)))
(snippet
'(begin
+ (delete-file-recursively "zlib")
+ (substitute* "Makefile.in"
+ ((" zlib/z.*\\.h") ""))
;; Delete files under GPL-compatible licences but never used
;; on GNU systems, rather than bloating the LICENSE field.
(delete-file "gui/serial_mac.cc") ; Apple MIT