summaryrefslogtreecommitdiff
path: root/gnu/packages/gnuzilla.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnuzilla.scm')
-rw-r--r--gnu/packages/gnuzilla.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 01b6245f8b..0b39774a2e 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -477,8 +477,8 @@ in C/C++.")
;; XXXX: Workaround 'snippet' limitations.
(define computed-origin-method (@@ (guix packages) computed-origin-method))
-(define %icecat-version "102.6.0-guix0-preview1")
-(define %icecat-build-id "20221213000000") ;must be of the form YYYYMMDDhhmmss
+(define %icecat-version "102.7.0-guix0-preview1")
+(define %icecat-build-id "20230117000000") ;must be of the form YYYYMMDDhhmmss
;; 'icecat-source' is a "computed" origin that generates an IceCat tarball
;; from the corresponding upstream Firefox ESR tarball, using the 'makeicecat'
@@ -500,11 +500,11 @@ in C/C++.")
"firefox-" upstream-firefox-version ".source.tar.xz"))
(sha256
(base32
- "1zhggzrk7lgip8jm37idh22qks76kmjy4yqy2qi63mvnv2j58cfj"))))
+ "1ahl66x8chnsz80capqa5ivyrqhc50s91zrcgz1jxd7w2ws61957"))))
- (upstream-icecat-base-version "102.6.0") ; maybe older than base-version
+ (upstream-icecat-base-version "102.7.0") ; maybe older than base-version
;;(gnuzilla-commit (string-append "v" upstream-icecat-base-version))
- (gnuzilla-commit "b6260130b9808f550bdb35061af2d7962109a181")
+ (gnuzilla-commit "7f76da3cfd5d04fa38d894f6ea6ac5f2fd0ea837")
(gnuzilla-source
(origin
(method git-fetch)
@@ -516,7 +516,7 @@ in C/C++.")
(string-take gnuzilla-commit 8)))
(sha256
(base32
- "19v443w43jbcl9m5kl52nfai7hs4j07nf2ad9ggca7b2b0cz89b4"))))
+ "19i66qvwzgllgnlw270bxphymybjj1qb5hdznqi4i2dcgpcrq77l"))))
;; 'search-patch' returns either a valid file name or #f, so wrap it
;; in 'assume-valid-file-name' to avoid 'local-file' warnings.
@@ -1097,8 +1097,8 @@ standards of the IceCat project.")
(cpe-name . "firefox_esr")
(cpe-version . ,(first (string-split version #\-)))))))
-(define %icedove-build-id "20221213000000") ;must be of the form YYYYMMDDhhmmss
-(define %icedove-version "102.6.0")
+(define %icedove-build-id "20230119000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-version "102.7.0")
;; Provides the "comm" folder which is inserted into the icecat source.
;; Avoids the duplication of Icecat's source tarball.
@@ -1107,11 +1107,11 @@ standards of the IceCat project.")
(method hg-fetch)
(uri (hg-reference
(url "https://hg.mozilla.org/releases/comm-esr102")
- (changeset "d46a947ae837300f19cc45c75d473c7b1cf4ebb3")))
+ (changeset "a786f143946e93a3059e6fe290bb954840ab9778")))
(file-name (string-append "thunderbird-" %icedove-version "-checkout"))
(sha256
(base32
- "0klr6i2sbaiv2gc8q1cxrz87zd5cskdwa9qacp3dhfb8x17qwb41"))))
+ "02pz9yhpp3lswjmvj30vbx05mbi31bnzzfwyw5v996zg5wz2fpyv"))))
(define-public icedove
(package