summaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 362e2047fa..13d2a68dba 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,7 +43,7 @@
(define-public babl
(package
(name "babl")
- (version "0.1.18")
+ (version "0.1.28")
(source (origin
(method url-fetch)
(uri (list (string-append "https://download.gimp.org/pub/babl/"
@@ -54,7 +54,7 @@
version ".tar.bz2")))
(sha256
(base32
- "1ygvnq22pf0zvf3bj7h67vvbpz7b8hhjvrr79ribws7sr5dljfj8"))))
+ "00w6xfcv960c98qvxv81gcbj8l1jiab9sggmdl77m19awwiyvwv3"))))
(build-system gnu-build-system)
(home-page "http://gegl.org/babl/")
(synopsis "Image pixel format conversion library")
@@ -83,26 +83,27 @@ provided as well as the framework to add new color models and data types.")
(patches (search-patches "gegl-CVE-2012-4433.patch"))))
(build-system gnu-build-system)
(arguments
- `(;; More than just the one test disabled below now fails; disable them
+ '(;; More than just the one test disabled below now fails; disable them
;; all according to the rationale given below.
#:tests? #f
+ #:configure-flags '("LDFLAGS=-lm")
#:phases
- (alist-cons-before
- 'build 'pre-build
- (lambda _
- ;; This test program seems to crash on exit. Specifically, whilst
- ;; g_object_unreffing bufferA and bufferB - This seems to be a bug
- ;; in the destructor. This is just a test program so will not have
- ;; any wider effect, although might be hiding another problem.
- ;; According to advice received on irc.gimp.org#gegl although 0.2.0
- ;; is the latest released version, any bug reports against it will
- ;; be ignored. So we are on our own.
- (substitute* "tools/img_cmp.c"
- (("g_object_unref \\(buffer.\\);") ""))
+ (modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda _
+ ;; This test program seems to crash on exit. Specifically, whilst
+ ;; g_object_unreffing bufferA and bufferB - This seems to be a bug
+ ;; in the destructor. This is just a test program so will not have
+ ;; any wider effect, although might be hiding another problem.
+ ;; According to advice received on irc.gimp.org#gegl although 0.2.0
+ ;; is the latest released version, any bug reports against it will
+ ;; be ignored. So we are on our own.
+ (substitute* "tools/img_cmp.c"
+ (("g_object_unref \\(buffer.\\);") ""))
- (substitute* "tests/compositions/Makefile"
- (("/bin/sh") (which "sh"))))
- %standard-phases)))
+ (substitute* "tests/compositions/Makefile"
+ (("/bin/sh") (which "sh")))
+ #t)))))
(inputs
`(("babl" ,babl)
("glib" ,glib)